summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-12-15 14:13:06 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2019-12-15 14:13:23 -0600
commit2d50c99c57ab6a6a20dd03a8f9caa23912a58383 (patch)
tree7e6f0a2499eeecfe7cd9a2d826de67b2d62fe22b
parentdev-tcltk/tkimg: fix DeprecatedInsinto (diff)
downloadgentoo-2d50c99c57ab6a6a20dd03a8f9caa23912a58383.tar.gz
gentoo-2d50c99c57ab6a6a20dd03a8f9caa23912a58383.tar.bz2
gentoo-2d50c99c57ab6a6a20dd03a8f9caa23912a58383.zip
dev-cpp/cpp-hocon: 0.2.1 bump with patch
Fixes: https://bugs.gentoo.org/703018 Package-Manager: Portage-2.3.81, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--dev-cpp/cpp-hocon/Manifest2
-rw-r--r--dev-cpp/cpp-hocon/cpp-hocon-0.2.1.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-cpp/cpp-hocon/Manifest b/dev-cpp/cpp-hocon/Manifest
index 43b70ed4a8ad..06f700ae18ee 100644
--- a/dev-cpp/cpp-hocon/Manifest
+++ b/dev-cpp/cpp-hocon/Manifest
@@ -1 +1,3 @@
DIST cpp-hocon-0.1.4.tar.gz 157988 BLAKE2B 3b9e3ec2c386446a2c1d078867b03fbfe2adc8160877288597c648eaf4af6e34f09b673780e6fb81ce9bd1724c1e3d6efc1102985d344a4d1d7bb48b15916190 SHA512 f5ee6c5e7eaa5139bb3c421fd8b7c0da337daec99dce7f426d567ced0036b7c49a396b1b9bdbaa8023cd776a5a942175082a4b30280d4211a0db51483324be42
+DIST cpp-hocon-0.2.1-boost-filesystem.patch 1004 BLAKE2B f1e8db5e00283b526a45155a705f25efcbe790a08518697facb70ec0adee21a0a954258c09527ee75d50b91cde4824193596c2a53af4f2613ddd709862840a14 SHA512 1c73065ace6ec957b0d7241f680e475708deedad43d2a200b4877350e0712dbf13aea8b0c12c7a0d02c12e2c0b3f201ae85b952969eb66e390276bed83a5d7ad
+DIST cpp-hocon-0.2.1.tar.gz 158108 BLAKE2B 4b7097768d4fcbc72df5c63fb036b12bb08108a0e1ef57ec182c64c2aa337b56197c8c10dea8f26f64a273b578d4c1b53a898024558d95e99d2ba1b3778c2414 SHA512 fcc377da7923b77436a6f2787d5b8b1b573f239de4f059c4a5949cbb1a755fd12024b9155f5e44cf60141181942f3e9a2a8fad07ee0b1d516fe2cd4a88d4ac8b
diff --git a/dev-cpp/cpp-hocon/cpp-hocon-0.2.1.ebuild b/dev-cpp/cpp-hocon/cpp-hocon-0.2.1.ebuild
new file mode 100644
index 000000000000..45f62697011e
--- /dev/null
+++ b/dev-cpp/cpp-hocon/cpp-hocon-0.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Provides C++ support for the HOCON configuration file format"
+HOMEPAGE="https://github.com/puppetlabs/cpp-hocon"
+SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/puppetlabs/cpp-hocon/commit/caab275509826dc5fe5ab2632582abb8f83ea2b3.patch -> ${PN}-0.2.1-boost-filesystem.patch"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=sys-devel/gcc-4.9.3:*
+ >=dev-libs/boost-1.54:=[nls]
+ >=dev-libs/leatherman-0.9.3:=
+ "
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ epatch "${DISTDIR}/${PN}-0.2.1-boost-filesystem.patch"
+
+ # make it support multilib
+ sed -i "s/\ lib)/\ $(get_libdir))/g" lib/CMakeLists.txt || die
+ sed -i "s/lib\")/$(get_libdir)\")/g" CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCMAKE_BUILD_TYPE=None
+ -DCMAKE_INSTALL_PREFIX=/usr
+ )
+ if use debug; then
+ mycmakeargs+=(
+ -DCMAKE_BUILD_TYPE=Debug
+ )
+ fi
+ cmake-utils_src_configure
+}