summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-06-06 11:33:24 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-06-06 11:33:24 +0200
commit2d6a6aba4f4c3304f6641b1743bf59c2d99b5b4f (patch)
tree22600b44ec12995dc706fff00abb9773172a0502
parentdev-util/drone-cli: Version bump to 1.1.1 (diff)
downloadgentoo-2d6a6aba.tar.gz
gentoo-2d6a6aba.tar.bz2
gentoo-2d6a6aba.zip
net-misc/istioctl: Version bump to 1.1.8
Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
-rw-r--r--net-misc/istioctl/Manifest1
-rw-r--r--net-misc/istioctl/istioctl-1.1.8.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-misc/istioctl/Manifest b/net-misc/istioctl/Manifest
index 088b03cec6c1..da42890dd6ed 100644
--- a/net-misc/istioctl/Manifest
+++ b/net-misc/istioctl/Manifest
@@ -1,3 +1,4 @@
DIST istioctl-1.1.4.tar.gz 20705247 BLAKE2B d3727dafcfa8a630a02040fe452a3a2b6c89d4dc2ede4128b9906adf21d97e68f8b126783d248239416a459357bee72ca0f2af19a6d34039ad59b3ade6f3b6d1 SHA512 e866fcad482ef605e4126fffe421eff7fbc1733e5d949e2ebe846f790d8825bb79d5360fe48d29913f0b015c15bc1aac224ac9f39e4e7d5948f2dcd5042570a8
DIST istioctl-1.1.6.tar.gz 20707819 BLAKE2B 0ebd34873e6ff1fec2413afed8b4fe80baee8e9bec55bc2fab15b25266b404fb05fce6bfd0e122c5eb3fa661f5633a431aaa3042ad6d12caf2c4feb58bdbaa5e SHA512 62b9b96547af6f8050f934e4d620ab1990afc805c0abbdbc7933220d28676542222b4452f8207dbe5976116bfe8ae557ee7545e1859b0ab22d9c0c2510950fca
DIST istioctl-1.1.7.tar.gz 20711283 BLAKE2B 5c6d54ab033f0dba19377d0ca1a88a57e319932c91d3c2c1f3ad9fc112f11aec481e4421b958490e5b3c24d3be6ae68dbc7122e17a7463585a052e225f77ae5b SHA512 8a00efd3fea05d3b28225bf6d58d46769aa7576851df849185d62a14ef368980df765d3c5b1d9c59dff7f0034259e62fe57bc119b66cecb220513f7b94500cef
+DIST istioctl-1.1.8.tar.gz 20718514 BLAKE2B 20b492932906bab3d8fd2e66452acf42a3b8fc07bb42e95217410b32ede68f2dc4256f4e33b104428996a3cfa2f30c798ccf2cc3794079c8936d353330763c88 SHA512 907bff4a7239e0e615fcc3ea92c98d944916dc88c744d574b5362e622729e8fb5a79e549a7f0beece5235918d7891ef6283e6b1e3f789980450d7eee1e131e2b
diff --git a/net-misc/istioctl/istioctl-1.1.8.ebuild b/net-misc/istioctl/istioctl-1.1.8.ebuild
new file mode 100644
index 000000000000..bf2567f64cbf
--- /dev/null
+++ b/net-misc/istioctl/istioctl-1.1.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-vcs-snapshot
+
+GIT_COMMIT="145b18a"
+
+KEYWORDS="~amd64"
+DESCRIPTION="Istio configuration command line utility"
+EGO_PN="istio.io/istio"
+HOMEPAGE="https://github.com/istio/istio"
+MY_PV=${PV/_/-}
+SRC_URI="https://github.com/istio/istio/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_compile() {
+ pushd "src/${EGO_PN}" || die
+ BUILDINFO="istio.io/istio/pkg/version.buildVersion=${PV}
+ istio.io/istio/pkg/version.buildGitRevision=${GIT_COMMIT}
+ istio.io/istio/pkg/version.buildStatus=Clean" \
+ VERBOSE=1 GOPATH="${WORKDIR}/${P}" TAG=${PV} emake istioctl
+ popd || die
+}
+
+src_install() {
+ dobin out/linux_amd64/release/${PN}
+ pushd "src/${EGO_PN}" || die
+ dodoc README.md
+}