summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-05-17 12:43:28 +0100
committerSam James <sam@gentoo.org>2021-05-17 21:09:22 +0000
commit2d9118e83e6c4c47e569ba129ff7eb9c9ce19fa6 (patch)
tree93a5a9780c20e40aae3c0ed347e6f91eb9e73d2b
parentdev-java/commons-configuration: Remove last-rited pkg (diff)
downloadgentoo-2d9118e83e6c4c47e569ba129ff7eb9c9ce19fa6.tar.gz
gentoo-2d9118e83e6c4c47e569ba129ff7eb9c9ce19fa6.tar.bz2
gentoo-2d9118e83e6c4c47e569ba129ff7eb9c9ce19fa6.zip
dev-java/commons-jelly: Remove last-rited pkg
Closes: https://bugs.gentoo.org/783165 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-java/commons-jelly/Manifest1
-rw-r--r--dev-java/commons-jelly/commons-jelly-1.0-r8.ebuild63
-rw-r--r--dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch59
-rw-r--r--dev-java/commons-jelly/metadata.xml8
-rw-r--r--profiles/package.mask1
5 files changed, 0 insertions, 132 deletions
diff --git a/dev-java/commons-jelly/Manifest b/dev-java/commons-jelly/Manifest
deleted file mode 100644
index 2664e8ef855b..000000000000
--- a/dev-java/commons-jelly/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST commons-jelly-1.0-src.tar.gz 174769 BLAKE2B 2dc43eef28c76252976616f0509aacbfed31ec0b99916730d86d084ec54bacc4f49000d04a953002717670d17a4ae2ae7249d57b327258414c3515dbb8abde7f SHA512 a72ae2dc8eea3fc19838f386dca38807a16326a3a93f483219212844f8ec033088b7721c78a4370f78a06cbee0c685144a2b16f171d54134822d06f653bcef35
diff --git a/dev-java/commons-jelly/commons-jelly-1.0-r8.ebuild b/dev-java/commons-jelly/commons-jelly-1.0-r8.ebuild
deleted file mode 100644
index 6cdda5bfc129..000000000000
--- a/dev-java/commons-jelly/commons-jelly-1.0-r8.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-ant-2
-
-MY_P="${P}-src"
-DESCRIPTION="A Java and XML based scripting and processing engine"
-HOMEPAGE="http://commons.apache.org/jelly/"
-SRC_URI="mirror://apache/jakarta/commons/jelly/source/${MY_P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="1"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-CDEPEND="
- dev-java/dom4j:1
- dev-java/junit:0
- dev-java/jaxen:1.1
- dev-java/commons-cli:1
- dev-java/commons-lang:0
- dev-java/commons-jexl:1.0
- dev-java/commons-logging:0
- dev-java/commons-discovery:0
- dev-java/commons-collections:0
- dev-java/commons-beanutils:1.7
- dev-java/tomcat-jstl-spec:0
- java-virtuals/servlet-api:3.0"
-RDEPEND="${CDEPEND}
- >=virtual/jre-1.6"
-DEPEND="${CDEPEND}
- >=virtual/jdk-1.6
- test? ( dev-java/ant-junit:0 )"
-
-S=${WORKDIR}/${MY_P}
-
-java_prepare() {
- # disables dependency fetching, and remove tests as a dependency of jar
- epatch "${FILESDIR}/${P}-gentoo.patch"
-}
-
-JAVA_ANT_REWRITE_CLASSPATH="yes"
-
-EANT_EXTRA_ARGS="-Dlibdir=."
-EANT_GENTOO_CLASSPATH="
- commons-beanutils-1.7,commons-cli-1,commons-collections,commons-discovery
- commons-jexl-1.0,commons-lang,commons-logging,dom4j-1,tomcat-jstl-spec
- jaxen-1.1,junit,servlet-api-3.0"
-
-src_test() {
- java-pkg-2_src_test
-}
-
-src_install() {
- java-pkg_newjar target/${P}.jar ${PN}.jar
- dodoc NOTICE.txt README.txt RELEASE-NOTES.txt
- use doc && java-pkg_dojavadoc dist/docs/api
- use source && java-pkg_dosrc src/java/*
-}
diff --git a/dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch b/dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch
deleted file mode 100644
index 8fafca81ea79..000000000000
--- a/dev-java/commons-jelly/files/commons-jelly-1.0-gentoo.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-diff -ru commons-jelly-1.0-src/build.xml commons-jelly-1.0-src-patched/build.xml
---- commons-jelly-1.0-src/build.xml 2005-06-16 10:39:44.000000000 -0400
-+++ commons-jelly-1.0-src-patched/build.xml 2005-09-04 19:39:19.000000000 -0400
-@@ -37,6 +37,8 @@
- <property name="proxy.password" value="">
- </property>
- <path id="build.classpath">
-+ <fileset dir="${libdir}" includes="**/*.jar"/>
-+ <!--
- <pathelement location="${libdir}/servletapi/jars/servletapi-2.3.jar">
- </pathelement>
- <pathelement location="${libdir}/commons-cli/jars/commons-cli-1.0.jar">
-@@ -67,6 +69,7 @@
- </pathelement>
- <pathelement location="${libdir}/xerces/jars/xerces-2.2.1.jar">
- </pathelement>
-+ -->
- </path>
- <target name="init" description="o Initializes some properties">
- <mkdir dir="${libdir}">
-@@ -92,7 +95,7 @@
- </and>
- </condition>
- </target>
-- <target name="compile" description="o Compile the code" depends="get-deps">
-+ <target name="compile" description="o Compile the code" depends="">
- <mkdir dir="${classesdir}">
- </mkdir>
- <javac destdir="${classesdir}" deprecation="true" debug="true" optimize="false" excludes="**/package.html">
-@@ -120,10 +123,12 @@
- <copy todir="${classesdir}/META-INF" file="${basedir}/LICENSE.txt">
- </copy>
- </target>
-- <target name="jar" description="o Create the jar" depends="compile,test">
-+
-+ <target name="jar" description="o Create the jar" depends="compile">
- <jar jarfile="${defaulttargetdir}/${final.name}.jar" excludes="**/package.html" basedir="${classesdir}">
- </jar>
- </target>
-+
- <target name="clean" description="o Clean up the generated directories">
- <delete dir="${defaulttargetdir}">
- </delete>
-@@ -213,7 +218,7 @@
- </fileset>
- </copy>
- </target>
-- <target name="javadoc" description="o Generate javadoc" depends="get-deps">
-+ <target name="javadoc" description="o Generate javadoc" depends="">
- <mkdir dir="${javadocdir}">
- </mkdir>
- <tstamp>
-@@ -432,4 +437,4 @@
- <unjar dest="${maven.home}" src="${user.home}/maven-install-latest.jar">
- </unjar>
- </target>
--</project>
-\ No newline at end of file
-+</project>
diff --git a/dev-java/commons-jelly/metadata.xml b/dev-java/commons-jelly/metadata.xml
deleted file mode 100644
index 2444066aa02b..000000000000
--- a/dev-java/commons-jelly/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
-</maintainer>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 5510328b4e58..bcbddb8a04fd 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -675,7 +675,6 @@ dev-util/findbugs
# Miroslav Ć ulc <fordfrog@gentoo.org> (2021-04-18)
# obsolete deps, not used by any package
# removal in 30 days
-dev-java/commons-jelly
dev-java/ezmorph
dev-java/ical4j