summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-02 18:21:35 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-02 19:37:39 +0200
commit2dc56fc92671917922e30cbc7405ab1782f51e21 (patch)
tree41d754ca4747c98f901001445034e0900942fd43
parentdev-python/pandas: Bump to 1.4.4 (diff)
downloadgentoo-2dc56fc9.tar.gz
gentoo-2dc56fc9.tar.bz2
gentoo-2dc56fc9.zip
dev-python/bpython: Bump to 0.23
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/bpython/Manifest1
-rw-r--r--dev-python/bpython/bpython-0.23.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/bpython/Manifest b/dev-python/bpython/Manifest
index 82fee5093f84..ed26796a02da 100644
--- a/dev-python/bpython/Manifest
+++ b/dev-python/bpython/Manifest
@@ -1 +1,2 @@
DIST bpython-0.22.1.tar.gz 217294 BLAKE2B 907b51753182add775d3e2ba08c3999d30ba23ab13d59f364d03ce5f22191e1a90031f7c3b5477fd00c94342a5ee204aa2618a7cd1a9470bbc898cfc266ba9bd SHA512 6b29235c41b645c3658812b8c80637d1e76029a6386f8628e5c681b2f3fdea653f89a12f4e28f55381464755e04fa7a33f023f096e75d889d5a588222c0d06c3
+DIST bpython-0.23.tar.gz 222241 BLAKE2B eae70242323534dacada4d3d181ec4fba5fd384dc124bec7f28db887d2f1fb5b49ec6bc169d4a93db9de88dee82d714d502f2b2b1de5d9d01073f7504430cc23 SHA512 b25b68a690b838fef0c5dbb05565db4373ebb3611278b9f94db792ef25a43f59e3e9b7ac1ad0f571ae442948748b6c5e28888c6aa0f592cdf8499223cfded217
diff --git a/dev-python/bpython/bpython-0.23.ebuild b/dev-python/bpython/bpython-0.23.ebuild
new file mode 100644
index 000000000000..b557b80cbb9e
--- /dev/null
+++ b/dev-python/bpython/bpython-0.23.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
+HOMEPAGE="
+ https://www.bpython-interpreter.org/
+ https://github.com/bpython/bpython/
+ https://pypi.org/project/bpython/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="clipboard +jedi urwid watch"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/curtsies-0.4.0[${PYTHON_USEDEP}]
+ dev-python/cwcwidth[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ clipboard? ( dev-python/pyperclip[${PYTHON_USEDEP}] )
+ jedi? ( dev-python/jedi[${PYTHON_USEDEP}] )
+ urwid? ( dev-python/urwid[${PYTHON_USEDEP}] )
+ watch? ( dev-python/watchdog[${PYTHON_USEDEP}] )
+"
+# sphinx is used implicitly to build manpages
+BDEPEND="
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+DOCS=( AUTHORS.rst CHANGELOG.rst )
+
+distutils_enable_sphinx doc/sphinx/source --no-autodoc
+distutils_enable_tests unittest