summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-01 17:12:33 +0100
committerSam James <sam@gentoo.org>2022-12-01 19:38:23 +0000
commit2dcc92ce6b5c947ea31350c635dcdce43fee527b (patch)
tree477f551d1e75c747314a9dcb46c8e5657ac5cb1f
parentapp-arch/gzip: Support app-alternatives/gzip (diff)
downloadgentoo-2dcc92ce6b5c947ea31350c635dcdce43fee527b.tar.gz
gentoo-2dcc92ce6b5c947ea31350c635dcdce43fee527b.tar.bz2
gentoo-2dcc92ce6b5c947ea31350c635dcdce43fee527b.zip
app-alternatives/bzip2: Simplify by chaining manpage references
Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/28494 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-alternatives/bzip2/bzip2-1.ebuild (renamed from app-alternatives/bzip2/bzip2-0.ebuild)9
1 files changed, 3 insertions, 6 deletions
diff --git a/app-alternatives/bzip2/bzip2-0.ebuild b/app-alternatives/bzip2/bzip2-1.ebuild
index 50e36d3cc7b2..6e61b5e2135d 100644
--- a/app-alternatives/bzip2/bzip2-0.ebuild
+++ b/app-alternatives/bzip2/bzip2-1.ebuild
@@ -30,22 +30,19 @@ src_install() {
if use lbzip2; then
dosym "${usr_prefix}lbzip2" /bin/bzip2
newman - bzip2.1 <<<".so lbzip2.1"
- newman - bunzip2.1 <<<".so lbzip2.1"
- newman - bzcat.1 <<<".so lbzip2.1"
elif use pbzip2; then
dosym "${usr_prefix}pbzip2" /bin/bzip2
newman - bzip2.1 <<<".so pbzip2.1"
- newman - bunzip2.1 <<<".so pbzip2.1"
- newman - bzcat.1 <<<".so pbzip2.1"
elif use reference; then
dosym bzip2-reference /bin/bzip2
newman - bzip2.1 <<<".so bzip2-reference.1"
- newman - bunzip2.1 <<<".so bzip2-reference.1"
- newman - bzcat.1 <<<".so bzip2-reference.1"
else
die "Invalid USE flag combination (broken REQUIRED_USE?)"
fi
dosym bzip2 /bin/bunzip2
dosym bzip2 /bin/bzcat
+
+ newman - bunzip2.1 <<<".so bzip2.1"
+ newman - bzcat.1 <<<".so bzip2.1"
}