summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-03-12 23:38:10 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-03-12 23:52:12 +0100
commit2dd4bf431a55bbe9b1412045233308b8494840ed (patch)
tree0e9acbc4579f77250c4fafd634c1d370486b2776
parentapp-emacs/buttercup: bump to 1.30 (diff)
downloadgentoo-2dd4bf431a55bbe9b1412045233308b8494840ed.tar.gz
gentoo-2dd4bf431a55bbe9b1412045233308b8494840ed.tar.bz2
gentoo-2dd4bf431a55bbe9b1412045233308b8494840ed.zip
app-emacs/yaml: bump to 0.5.2
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/yaml/Manifest1
-rw-r--r--app-emacs/yaml/yaml-0.5.2.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-emacs/yaml/Manifest b/app-emacs/yaml/Manifest
index 4035343c164a..f5e989a0a882 100644
--- a/app-emacs/yaml/Manifest
+++ b/app-emacs/yaml/Manifest
@@ -1 +1,2 @@
DIST yaml-0.5.1.tar.gz 44335 BLAKE2B dbcaf29d5d0a18e167cf0fd43d5ea0536d3879ed8bc924930c06aa1eedb2c268f91fd2d0c8981ab81f928db82148ad7fbc01a5926b3dd4645ec57cc78bac7256 SHA512 4ed2dc26a87137deb2d06cffac7c9b0748f66a9b05d91e33022da0edee0966b94ac2dfdb5a181628357dd3714ac55cfb48b1a35f9f6352c01d745a1d69131381
+DIST yaml-0.5.2.tar.gz 44466 BLAKE2B 9f754a43bb427ea3a76de6f6fecf44701f329a0072bd060d93a437f76564faeb1ffe4a0aeb109ac491e4a664de5faf738fec69a97cf872ddbfc91796dcf4355a SHA512 4f50585a7ce4304df1b65cde6e295ecb42c401a8eb07f45b22cee8d77e6fdcf954266adb89b6c1cf495142fd32298346703164393f98ac0164beaceb779ceac3
diff --git a/app-emacs/yaml/yaml-0.5.2.ebuild b/app-emacs/yaml/yaml-0.5.2.ebuild
new file mode 100644
index 000000000000..a706ed730c6d
--- /dev/null
+++ b/app-emacs/yaml/yaml-0.5.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=25.1
+
+inherit elisp
+
+DESCRIPTION="YAML parser in Emacs Lisp"
+HOMEPAGE="https://github.com/zkry/yaml.el/"
+SRC_URI="https://github.com/zkry/yaml.el/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/yaml.el-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DOCS=( README.md )
+SITEFILE="50${PN}-gentoo.el"
+
+src_test() {
+ # "test/string-inflection-test.el" calls "(ert-run-tests-batch t)"
+ ${EMACS} ${EMACSFLAGS} -L . -l yaml-tests.el || die
+}