summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-11-14 17:30:41 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-15 16:25:07 +0100
commit2dd89bebd8a6ffb5dfb74d9dc2cc13c014bc4707 (patch)
tree0e66d7cfa70a84308d6eb341d19aebd45afcc940
parentnet-libs/nodejs: Version bump. (diff)
downloadgentoo-2dd89beb.tar.gz
gentoo-2dd89beb.tar.bz2
gentoo-2dd89beb.zip
media-libs/adplug: Add live ebuild
Package-Manager: Portage-2.3.13, Repoman-2.3.4
-rw-r--r--media-libs/adplug/adplug-9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/media-libs/adplug/adplug-9999.ebuild b/media-libs/adplug/adplug-9999.ebuild
new file mode 100644
index 000000000000..b44d43a3eae6
--- /dev/null
+++ b/media-libs/adplug/adplug-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A free, cross-platform, hardware independent AdLib sound player library"
+HOMEPAGE="http://adplug.sourceforge.net"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/adplug/adplug.git"
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="debug static-libs"
+
+RDEPEND=">=dev-cpp/libbinio-1.4"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}