summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-04 09:36:59 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-04 09:39:51 -0500
commit2e1e317887bcbba946f2da1dda3808d91f957450 (patch)
tree994e4769c8cd0fff4ec28e7c3429f4349baec356
parentapp-crypt/certbot-apache: 0.33.0 bump (diff)
downloadgentoo-2e1e3178.tar.gz
gentoo-2e1e3178.tar.bz2
gentoo-2e1e3178.zip
app-crypt/certbot-nginx: 0.33.0 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-crypt/certbot-nginx/Manifest1
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-0.33.0.ebuild34
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-9999.ebuild6
3 files changed, 38 insertions, 3 deletions
diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
index 2bb930b04665..7e612162e2a7 100644
--- a/app-crypt/certbot-nginx/Manifest
+++ b/app-crypt/certbot-nginx/Manifest
@@ -1,2 +1,3 @@
DIST certbot-0.31.0.tar.gz 1267960 BLAKE2B 4097a3d278d86589e7273c3f5c4f809f0a5777319856a2aea27233ee99eadf2e7c075c5400970be6a2f11032e54457c9705ef45b85e9d158bc04c7761e59a23a SHA512 9202800649691e9b2d6b4c898b975d11ef3aba8f34903c93a11eafa5300f64c939547cfbbe34ac664de293d2540b143f14d3117969e4a6dfc55d624cfae44fea
DIST certbot-0.32.0.tar.gz 1284873 BLAKE2B c3fa538de87b67680a7bc7465d77ab2947606aec4def3717b5d942c83254ff758d751e137bfe33cb6f9362a11a9bad7fba0337927b638f3af7ddf304d408c447 SHA512 fa61e975d2ce09efa3570118f220cd9f9d2fc8d5ab408feb4c4e50bfa795cb28be6c7a78497fb10bc91e577e908126988197ae5d016be4823c5c4ddb68cbf5a4
+DIST certbot-0.33.0.tar.gz 1303989 BLAKE2B 7417e72592e15fd7969aed4c60a799caaeedfe66af3b2e60f364677bbf7ba5dde6e597e89a07036b61e63975b402e3de81fb116ee4861061357160284fcc7821 SHA512 4a653e5e7b62d938a46421df509063a3aedf978b73cf3b44088408bf3c48b70c70fe595c449fe9df54e5724c2d5c03357be434b305f5378eaa8261f811678133
diff --git a/app-crypt/certbot-nginx/certbot-nginx-0.33.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-0.33.0.ebuild
new file mode 100644
index 000000000000..9adf3132423f
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-0.33.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/${PN%-nginx}/${PN%-nginx}/archive/v${PV}.tar.gz -> ${PN%-nginx}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+ S=${WORKDIR}/${PN%-nginx}-${PV}/${PN}
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="Nginx plugin for certbot (Let's Encrypt Client)"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ >=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-0.33.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
diff --git a/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild b/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
index b3315cd42643..9adf3132423f 100644
--- a/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
+++ b/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -25,8 +25,8 @@ IUSE=""
CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="${CDEPEND}
- >=app-crypt/certbot-0.22.0[${PYTHON_USEDEP}]
- >=app-crypt/acme-0.26.0[${PYTHON_USEDEP}]
+ >=app-crypt/acme-0.29.0[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-0.33.0[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
dev-python/pyopenssl[${PYTHON_USEDEP}]
>=dev-python/pyparsing-1.5.5[${PYTHON_USEDEP}]