summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-11-14 07:09:16 +0200
committerMichał Górny <mgorny@gentoo.org>2023-11-14 14:22:44 +0100
commit2e25d6f9f59e580aceed2709c70c7fab37c5f7c5 (patch)
tree9c348ca11800de52a2430d86172ad15c0e942696
parentdev-python/graphviz: enable pypy3 (diff)
downloadgentoo-2e25d6f9f59e580aceed2709c70c7fab37c5f7c5.tar.gz
gentoo-2e25d6f9f59e580aceed2709c70c7fab37c5f7c5.tar.bz2
gentoo-2e25d6f9f59e580aceed2709c70c7fab37c5f7c5.zip
dev-python/pipdeptree: add 2.13.1
Closes: https://bugs.gentoo.org/917320 Closes: https://bugs.gentoo.org/917321 Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/33816 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pipdeptree/Manifest1
-rw-r--r--dev-python/pipdeptree/files/pipdeptree-2.13.1-expect-hpy-in-pypy-7.3.3.patch26
-rw-r--r--dev-python/pipdeptree/pipdeptree-2.13.1.ebuild41
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/pipdeptree/Manifest b/dev-python/pipdeptree/Manifest
index 3257b50c00fb..f2857ce4b8be 100644
--- a/dev-python/pipdeptree/Manifest
+++ b/dev-python/pipdeptree/Manifest
@@ -1 +1,2 @@
DIST pipdeptree-2.13.0.tar.gz 32980 BLAKE2B 37a7ecf2cef1fb2533655b1b911216ed5d069ce639198896517a49be010b1697df2a81aecba001dfbcd9b67618411754a97ad198f2e2c32d73d2104020d5eb01 SHA512 eccc41e1428d2f7146386a6aa0e1c5833302b9eaaa810250cb8029f8cf7f8f8173477553f143835b4dfac318331b9b7467493a3fcae15569d7d371d58b27963f
+DIST pipdeptree-2.13.1.tar.gz 33139 BLAKE2B e7044303f09ad3952e14f79ec11e01a54e9c34ff5b4430094a968602c8a97388eadd4e021c97c97c1767d7ae02b7070ff6e4ec934aef6036b98bf2553d2344a0 SHA512 18c73a8ef458b0a241d967da40453fb8a9fc6550cbd2c21eecca9a81f011b896622fb45a81b79e30eb990454b6f518a1fcc02cb25bb2c5ca988b44e040264e26
diff --git a/dev-python/pipdeptree/files/pipdeptree-2.13.1-expect-hpy-in-pypy-7.3.3.patch b/dev-python/pipdeptree/files/pipdeptree-2.13.1-expect-hpy-in-pypy-7.3.3.patch
new file mode 100644
index 000000000000..5cc4b1ca580d
--- /dev/null
+++ b/dev-python/pipdeptree/files/pipdeptree-2.13.1-expect-hpy-in-pypy-7.3.3.patch
@@ -0,0 +1,26 @@
+https://github.com/tox-dev/pipdeptree/pull/302
+
+From 8a2ccfe062d8978f010e2e4bd3f8e8b9e46ecbce Mon Sep 17 00:00:00 2001
+From: Alfred Wingate <parona@protonmail.com>
+Date: Tue, 14 Nov 2023 08:36:09 +0200
+Subject: [PATCH] Expect hpy in pypy versions >= 7.3.3
+
+Signed-off-by: Alfred Wingate <parona@protonmail.com>
+--- a/tests/test_non_host.py
++++ b/tests/test_non_host.py
+@@ -33,7 +33,11 @@ def test_custom_interpreter(
+ if implementation == "CPython":
+ expected = {"pip", "setuptools", "wheel"}
+ elif implementation == "PyPy":
+- expected = {"cffi", "greenlet", "pip", "readline", "setuptools", "wheel"}
++ # hpy added in 7.3.2, enabled in 7.3.3
++ if sys.pypy_version_info >= (7, 3, 3):
++ expected = {"cffi", "greenlet", "hpy", "pip", "readline", "setuptools", "wheel"}
++ else:
++ expected = {"cffi", "greenlet", "pip", "readline", "setuptools", "wheel"}
+ else:
+ raise ValueError(implementation)
+ if sys.version_info >= (3, 12):
+--
+2.42.1
+
diff --git a/dev-python/pipdeptree/pipdeptree-2.13.1.ebuild b/dev-python/pipdeptree/pipdeptree-2.13.1.ebuild
new file mode 100644
index 000000000000..419254577378
--- /dev/null
+++ b/dev-python/pipdeptree/pipdeptree-2.13.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="Utility for displaying installed packages in a dependency tree"
+HOMEPAGE="
+ https://github.com/tox-dev/pipdeptree/
+ https://pypi.org/project/pipdeptree/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/graphviz[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ # https://github.com/tox-dev/pipdeptree/pull/302
+ "${FILESDIR}/pipdeptree-2.13.1-expect-hpy-in-pypy-7.3.3.patch"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature \
+ "visualising the dependency graph with --graph-output" \
+ dev-python/graphviz
+}