summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-08-20 11:39:06 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-09-15 11:09:23 +0300
commit2e4be91174f284c1cc57f664cf265b1516509db5 (patch)
treec671afc90c3293ebaba574f982c9cb85e4fd7f90
parentdev-python/spyder-line-profiler: does not work with spyder-5 (diff)
downloadgentoo-2e4be911.tar.gz
gentoo-2e4be911.tar.bz2
gentoo-2e4be911.zip
dev-python/spyder-memory-profiler: does not work with spyder-5
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--dev-python/spyder-memory-profiler/spyder-memory-profiler-0.2.1.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/dev-python/spyder-memory-profiler/spyder-memory-profiler-0.2.1.ebuild b/dev-python/spyder-memory-profiler/spyder-memory-profiler-0.2.1.ebuild
index 6a7df158ca88..44303fc8b16d 100644
--- a/dev-python/spyder-memory-profiler/spyder-memory-profiler-0.2.1.ebuild
+++ b/dev-python/spyder-memory-profiler/spyder-memory-profiler-0.2.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_7 )
+PYTHON_COMPAT=( python3_{7,8} )
inherit distutils-r1 virtualx
@@ -15,12 +15,15 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND=">=dev-python/spyder-4.0.0[${PYTHON_USEDEP}]
- dev-python/memory_profiler[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/memory_profiler[${PYTHON_USEDEP}]
+ >=dev-python/spyder-4.0.0[${PYTHON_USEDEP}]
+ <dev-python/spyder-5.0.0[${PYTHON_USEDEP}]
+"
DEPEND="test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest-qt[${PYTHON_USEDEP}] )"
+ dev-python/pytest-qt[${PYTHON_USEDEP}]
+)"
distutils_enable_tests pytest