summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-04-21 16:48:49 +0100
committerMarek Szuba <marecki@gentoo.org>2020-04-21 16:51:52 +0100
commit2e4d1f7f3e459026eefc17097d45e15c10868eb7 (patch)
tree597ca8b2a66ef553a89c087b8820cfdc66ec7b06
parentsys-kernel/vanilla-sources: Automated version bump to {4.19.117,5.4.34,5.6.6}... (diff)
downloadgentoo-2e4d1f7f3e459026eefc17097d45e15c10868eb7.tar.gz
gentoo-2e4d1f7f3e459026eefc17097d45e15c10868eb7.tar.bz2
gentoo-2e4d1f7f3e459026eefc17097d45e15c10868eb7.zip
dev-python/pslab-python: support python3_7
Also make better use of distutils-r1 and make Python dependencies actually sane (no idea what I was on when I committed that). Nb. having had a look at upstream CI this *should* work with 3.8 as well, will have to add support for this version to dev-python/pyqtgraph first though. Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--dev-python/pslab-python/pslab-python-1.0.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/pslab-python/pslab-python-1.0.1-r1.ebuild b/dev-python/pslab-python/pslab-python-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..71659cc6f68f
--- /dev/null
+++ b/dev-python/pslab-python/pslab-python-1.0.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for communicating with Pocket Science Lab"
+HOMEPAGE="https://pslab.io"
+SRC_URI="https://github.com/fossasia/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyqtgraph[${PYTHON_USEDEP}]
+ dev-python/pyserial[${PYTHON_USEDEP}]
+ sci-libs/scipy[${PYTHON_USEDEP}]
+ ')"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.1-sys_version.patch
+ "${FILESDIR}"/${PN}-1.0.1-no_install_udev_rules.patch
+)
+
+distutils_enable_sphinx docs