summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-26 20:38:06 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-26 20:38:06 -0600
commit2e4f275083be9d884e98c97dce67136c9a49c255 (patch)
tree8f5fd77b3266a1a9d13b722a24787e374e3d67ad
parentdev-python/taskflow: bup (diff)
downloadgentoo-2e4f2750.tar.gz
gentoo-2e4f2750.tar.bz2
gentoo-2e4f2750.zip
dev-python/WSME: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-python/WSME/Manifest1
-rw-r--r--dev-python/WSME/WSME-0.9.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/WSME/Manifest b/dev-python/WSME/Manifest
index 9b16edefb2ba..5a3886cf2ef3 100644
--- a/dev-python/WSME/Manifest
+++ b/dev-python/WSME/Manifest
@@ -1 +1,2 @@
DIST WSME-0.8.0.tar.gz 121619 SHA256 00241e4e4e40d6183f6354a8f5659b601753d49e28b6e5aca332bdf2e31188db SHA512 a0fb92a16bf3a3df75c71ad8756a18e97ee6ab381ad954898970a5eec93cae5469a8fa07a8724cfc64e53d3ad3c3d7d7feaaa55b92176bfb24fc566bd7f415a7 WHIRLPOOL 542f46ffab012f83d18c7c10d4e681f2ae775d0995d48c29a68b7c0b4a7f1cff7fc16d88251f73c4bf04740947d35dc7b5f6c68391e0d05ae5e29cee9bc4ea82
+DIST WSME-0.9.1.tar.gz 123187 SHA256 afdd3ba14f815837239d6dead652de460bd61a869e39430b459be77d1a928197 SHA512 795cd780f54e4b4b25d7ae5bee75f3b8d1513b315dbd8f056051452181be4f2067b06db9e695585c0d2b00474c2e2d7c75bbf4ec57519f9343c8cc184389ca4f WHIRLPOOL 945fa54af366cedd25e5cf463464aa178ffc08ec5f13d25449630b80a18716bbabd5598379feba389c956120d3136c82ecff23f7782afda5924220cc09daaf61
diff --git a/dev-python/WSME/WSME-0.9.1.ebuild b/dev-python/WSME/WSME-0.9.1.ebuild
new file mode 100644
index 000000000000..62ae7e59d89a
--- /dev/null
+++ b/dev-python/WSME/WSME-0.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simplify the writing of REST APIs, and extend them with additional protocols."
+HOMEPAGE="http://pythonhosted.org//WSME"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.3[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2.3[${PYTHON_USEDEP}]
+ dev-python/simplegeneric[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.12[${PYTHON_USEDEP}]
+"