summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-11-29 09:12:59 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-12-12 21:54:56 +0100
commit2e7ccf54c87f358eec11b3187250e5afeeb375d0 (patch)
tree897a059ae6eeeef2c867866b104f6f03569eee68
parentapp-text/sgml-common: EAPI 6 bump and update HOMPAGE. (diff)
downloadgentoo-2e7ccf54c87f.tar.gz
gentoo-2e7ccf54c87f.tar.bz2
gentoo-2e7ccf54c87f.zip
dev-python/qtconsole: version bump to 4.3.1.
Package-Manager: Portage-2.3.13, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6342
-rw-r--r--dev-python/qtconsole/qtconsole-4.3.1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/qtconsole/qtconsole-4.3.1.ebuild b/dev-python/qtconsole/qtconsole-4.3.1.ebuild
new file mode 100644
index 000000000000..ef832b246086
--- /dev/null
+++ b/dev-python/qtconsole/qtconsole-4.3.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/ipykernel[${PYTHON_USEDEP}]
+ dev-python/ipython_genutils[${PYTHON_USEDEP}]
+ dev-python/jupyter_core[${PYTHON_USEDEP}]
+ >=dev-python/jupyter_client-4.1.1[${PYTHON_USEDEP}]
+ dev-python/traitlets[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? (
+ >=dev-python/ipython-4.0.0-r2[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.3.1-r1[${PYTHON_USEDEP}]
+ )
+ test? (
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' 'python2*')
+ >=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP},svg,testlib]
+ )
+ dev-python/PyQt5[${PYTHON_USEDEP},svg]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyzmq-13[${PYTHON_USEDEP}]
+ "
+PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ # Prevent un-needed download during build
+ if use doc; then
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/build/html/. )
+ fi
+}
+
+python_test() {
+ # jupyter qtconsole --generate-config ... jupyter-qtconsole: cannot connect to X server
+ # ERROR
+ sed \
+ -e 's:test_generate_config:_&:g' \
+ -i qtconsole/tests/test_app.py || die
+ virtx nosetests --verbosity=2 qtconsole
+}