summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2022-10-11 19:43:16 -0300
committerMatt Turner <mattst88@gentoo.org>2022-10-11 21:53:56 -0400
commit2e82872d79fe17b26b07d0f71458212deaaf3feb (patch)
tree0c00867b3c27d33a1401e4ef062bb9ea28864fa5
parentnet-misc/gupnp-tools: Version bump to 0.12.0 (diff)
downloadgentoo-2e82872d79fe17b26b07d0f71458212deaaf3feb.tar.gz
gentoo-2e82872d79fe17b26b07d0f71458212deaaf3feb.tar.bz2
gentoo-2e82872d79fe17b26b07d0f71458212deaaf3feb.zip
net-libs/libsoup: Version bump to 2.74.3
Closes: https://github.com/gentoo/gentoo/pull/27747 Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--net-libs/libsoup/Manifest1
-rw-r--r--net-libs/libsoup/libsoup-2.74.3.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/net-libs/libsoup/Manifest b/net-libs/libsoup/Manifest
index 459faf2ff230..ef7c3d56633a 100644
--- a/net-libs/libsoup/Manifest
+++ b/net-libs/libsoup/Manifest
@@ -1,3 +1,4 @@
DIST libsoup-2.74.2.tar.xz 1497356 BLAKE2B b05e5d06e20a95042334c79e3a633ec43db0e7444b425f8577045fbdee7b78bd697e743f4283ed79265bbe538145a541ef2ef55636ae235667a89d00910d5bf2 SHA512 6f9da3296364e210103093cef9ef34fb40f694a8ef90966fc1fbd834c11f3db1031784a0901e9181bf3124e0682708148bd3598a31d60f1cce61eaae2e19ba7a
+DIST libsoup-2.74.3.tar.xz 1504804 BLAKE2B 91f441197414314bb78cf15e7c13b54714e669145784812fb7a68cc41c8965ea29c53dc686d690e00f28f711be9f767038e5cc43b11aa0136f190dd2d41ec2a0 SHA512 72f8a055df984cb35105fe67f4ca67d3fb110d40a9cacb660fccd89f93b06bc32e25d94375dcc76608a245f7c5e081d968d7aaf5952eb16013d81c741247cb4c
DIST libsoup-3.0.8.tar.xz 1535496 BLAKE2B 7f5531f7771df557e6ce65ae684ba83c9eeddf98547f1c025204f17a087fc1ec34ed6baf7c278528d41b4298a694bb9cb0726387dae6f313b896c9dfba2d2c57 SHA512 91d7de5dc642bfc1aa69fed9686fcafcc10094f3ae568f827dcebecfc9c919a00486b93c5f43710628cb3ab415bd7146d28455c5f9e916f4fe57ff4c0e66ad56
DIST libsoup-3.2.0.tar.xz 1526272 BLAKE2B 782e872fd135d1b9fead3714ca0bdb3884b38baaf54bf2dd91212a6b362c818f8046a829bcdb57de255dad12bf4e5ca0682bbd8acd529b28a2d3fca8db6239bd SHA512 e4dc4cda297ec2c2e8ced82d141e00c186b552c9308eb0d05d55a1397de1b037d8fe053ea0ada12691ce7c0ff42c03f5f8177049005a1455cc3b0e1df77c99ea
diff --git a/net-libs/libsoup/libsoup-2.74.3.ebuild b/net-libs/libsoup/libsoup-2.74.3.ebuild
new file mode 100644
index 000000000000..64c87fbeb301
--- /dev/null
+++ b/net-libs/libsoup/libsoup-2.74.3.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome.org meson-multilib vala xdg
+
+DESCRIPTION="HTTP client/server library for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Projects/libsoup"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.4"
+
+# TODO: Default enable brotli at some point? But in 2.70.0 not advertised to servers yet - https://gitlab.gnome.org/GNOME/libsoup/issues/146
+IUSE="brotli gssapi gtk-doc +introspection samba ssl sysprof test +vala"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.58:2[${MULTILIB_USEDEP}]
+ >=dev-db/sqlite-3.8.2:3[${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.9.1-r4:2[${MULTILIB_USEDEP}]
+ brotli? ( >=app-arch/brotli-1.0.6-r1:=[${MULTILIB_USEDEP}] )
+ >=net-libs/libpsl-0.20[${MULTILIB_USEDEP}]
+ sysprof? ( >=dev-util/sysprof-capture-3.40.1:4[${MULTILIB_USEDEP}] )
+ sys-libs/zlib
+ gssapi? ( virtual/krb5[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ samba? ( net-fs/samba )
+"
+RDEPEND="${DEPEND}
+ >=net-libs/glib-networking-2.38.2[ssl?,${MULTILIB_USEDEP}]
+"
+BDEPEND="
+ dev-libs/glib
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1.20
+ app-text/docbook-xml-dtd:4.1.2 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+# test? ( www-servers/apache[ssl,apache2_modules_auth_digest,apache2_modules_alias,apache2_modules_auth_basic,
+# apache2_modules_authn_file,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_dir,
+# apache2_modules_mime,apache2_modules_proxy,apache2_modules_proxy_http,apache2_modules_proxy_connect]
+# dev-lang/php[apache2,xmlrpc]
+# net-misc/curl
+# net-libs/glib-networking[ssl])"
+
+PATCHES=(
+ # Disable apache tests until they are usable on Gentoo, bug #326957
+ "${FILESDIR}"/disable-apache-tests.patch
+)
+
+src_prepare() {
+ use vala && vala_src_prepare
+ xdg_src_prepare
+ # https://gitlab.gnome.org/GNOME/libsoup/issues/159 - could work with libnss-myhostname
+ sed -e '/hsts/d' -i tests/meson.build || die
+}
+
+src_configure() {
+ # FIXME: we need addpredict to workaround bug #324779 until
+ # root cause (bug #249496) is solved
+ # But necessary while apache tests are disabled
+ #addpredict /usr/share/snmp/mibs/.index
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_feature gssapi)
+ -Dkrb5_config="${CHOST}-krb5-config"
+ $(meson_feature samba ntlm)
+ $(meson_feature brotli)
+ -Dntlm_auth="${EPREFIX}/usr/bin/ntlm_auth"
+ -Dtls_check=false # disables check, we still rdep on glib-networking
+ -Dgnome=false
+ $(meson_native_use_feature introspection)
+ $(meson_native_use_feature vala vapi)
+ $(meson_native_use_bool gtk-doc gtk_doc)
+ $(meson_use test tests)
+ -Dinstalled_tests=false
+ $(meson_feature sysprof)
+ )
+ meson_src_configure
+}