summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2016-07-23 20:03:09 -0500
committerAlex Brandt <alunduil@gentoo.org>2016-07-23 20:03:09 -0500
commit2e8b289502ca5663192389fc481882ce66926a11 (patch)
treebfdca9f081d015b75f81bf462920db217be869ca
parentapp-text/podofo: version bump to 0.9.4 (diff)
downloadgentoo-2e8b2895.tar.gz
gentoo-2e8b2895.tar.bz2
gentoo-2e8b2895.zip
dev-python/botocore: add version 1.4.37
Package-Manager: portage-2.3.0
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.4.37.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 305a08a70cd5..d18a8782ceb4 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,3 +2,4 @@ DIST botocore-1.3.22.tar.gz 2349601 SHA256 02a6d320b09179bc5dcbafd4be732d9431bfe
DIST botocore-1.4.28.tar.gz 2503928 SHA256 145e41531a5d38862974ddf45c055e1561046f72caa04564f0435d25cf62dbe1 SHA512 51feb906bc82c66054d0b4b09041377c67839cfbe9dcf39975060b3c1acb9d8e5607fb43e93199d321ab890410550de7f7812598aeecad6709ce1317a19a3bc6 WHIRLPOOL d089d9d5a038cb8253d7a4194d66972e1ac1a0ddb92d90e3bf8a48de9c87a74ddbccef7eebe475f778ad03d6a7102c38d1905016600d51848bcef9c584136821
DIST botocore-1.4.31.tar.gz 2622913 SHA256 c526e5f160f1d244c014bf59d013d4a3ba6037e62826ef9ab6c01bbb2a5ef013 SHA512 395de78cc39fed1e89f913e55e8d2f64b05b5e459831e3f46e7c88f4b13f6291cab252dc650137d994abfb3b4f5afdad939c175214588e668971c8b180e8310b WHIRLPOOL cdfa6c9a7d0a16e1e464db9ea678fe4374211a4d65e0e4de539228c35dc3269527df0095effa666c6414293902b172299f592264652dc2ef32c264afaade52e7
DIST botocore-1.4.34.tar.gz 2630600 SHA256 a649ab5f9d9ddaa235510f62939e874aa3e37677564319883337ef9e98b7e5a1 SHA512 e683bf6881f9339a7431a085be274124e362a1b8ab538ae0589f7c266b160078e991ac27b2e5e5321c26f008ab548298abb382bd2d5b927866263b60ba67bb8d WHIRLPOOL 8f2d5e1c729cdbfeea29c416fc114e2c3ef10c9f09aa4098176547e7c7b54e7e2dbd0818f1147f13532f375da96943e4f4f5886c1d2809910c8527493937d956
+DIST botocore-1.4.37.tar.gz 2642647 SHA256 20dc1a0bf37019cac33e0f76d04a2831f2786cbee17f54da0e32a93caf86ef49 SHA512 033b7a03b9428cfeffaf0bd805a3ef94487b01b00aa9991eb11bba5a7e2a657c22e525b88f9879114ce170ca98a6727498b40879d6f899c1126dab81321eee47 WHIRLPOOL 0f00332660cd8f858b32f70a850f19b279494b31f70c2210da0c82c23a7ef10eeab904dcce087f382cc5cb284e802baf695601e2c3ab2caa53e19cb2b8873630
diff --git a/dev-python/botocore/botocore-1.4.37.ebuild b/dev-python/botocore/botocore-1.4.37.ebuild
new file mode 100644
index 000000000000..9c57e3342b4c
--- /dev/null
+++ b/dev-python/botocore/botocore-1.4.37.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="
+ >=dev-python/docutils-0.10[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ <dev-python/jmespath-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.1[${PYTHON_USEDEP}]
+ <dev-python/python-dateutil-3.0.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/guzzle_sphinx_theme-0.7.10[${PYTHON_USEDEP}]
+ <dev-python/guzzle_sphinx_theme-0.8[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.3[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ ~dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests tests/unit || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+
+ distutils-r1_python_install_all
+}