summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-10-10 10:56:52 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-10-10 11:18:24 +0300
commit2e91e8ba15964aba3db63b01d9ab9624ee2c84ca (patch)
tree59f56ee7f5d32abaac82312bb48cff86a49ddeec
parentdev-python/executing: add 1.1.1 (diff)
downloadgentoo-2e91e8ba15964aba3db63b01d9ab9624ee2c84ca.tar.gz
gentoo-2e91e8ba15964aba3db63b01d9ab9624ee2c84ca.tar.bz2
gentoo-2e91e8ba15964aba3db63b01d9ab9624ee2c84ca.zip
dev-python/executing: add asttokens as optional dep
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/executing/executing-1.1.1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-python/executing/executing-1.1.1.ebuild b/dev-python/executing/executing-1.1.1.ebuild
index 26b7519766f7..eb688d352f1f 100644
--- a/dev-python/executing/executing-1.1.1.ebuild
+++ b/dev-python/executing/executing-1.1.1.ebuild
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{8..11} )
-inherit distutils-r1
+inherit distutils-r1 optfeature
DESCRIPTION="Get information about what a Python frame is currently doing"
HOMEPAGE="
@@ -22,7 +22,6 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-# asttokens is optional runtime dep
BDEPEND="
dev-python/setuptools_scm[${PYTHON_USEDEP}]
test? (
@@ -41,3 +40,7 @@ python_test() {
"${EPYTHON}" tests/test_main.py || die "Tests failed with ${EPYTHON}"
epytest tests/test_pytest.py
}
+
+pkg_postinst() {
+ optfeature "getting node's source code" dev-python/asttokens
+}