summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-09-17 10:57:20 +0200
committerMichał Górny <mgorny@gentoo.org>2017-09-28 15:15:06 +0200
commit2e93c3f599c01ed54e1d6d062073993d14c47bd8 (patch)
tree14eeddf3eebe29ac5162ef46b58cb4834a9d5eee
parentmedia-libs/mesa: Split LLVM RDEP into sep block (diff)
downloadgentoo-2e93c3f5.tar.gz
gentoo-2e93c3f5.tar.bz2
gentoo-2e93c3f5.zip
media-libs/mesa: Move radeonsi dep to RDEP
Even if the relevant LLVM target is only strictly required at build-time, mesa links to all targets anyway and removing any of them will break link chain.
-rw-r--r--media-libs/mesa/mesa-9999.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index d9a7ac09fccf..947195bb11a7 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -144,6 +144,10 @@ RDEPEND="${RDEPEND}
llvm? (
video_cards_radeonsi? (
vulkan? ( >=sys-devel/llvm-3.9.0:=[${MULTILIB_USEDEP}] )
+ || (
+ sys-devel/llvm[llvm_targets_AMDGPU]
+ sys-devel/llvm[video_cards_radeon]
+ )
)
>=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
)
@@ -153,12 +157,6 @@ RDEPEND="${RDEPEND}
# LLVM < 3.9 is out of the game
DEPEND="${RDEPEND}
${PYTHON_DEPS}
- llvm? (
- video_cards_radeonsi? ( || (
- sys-devel/llvm[llvm_targets_AMDGPU]
- sys-devel/llvm[video_cards_radeon]
- ) )
- )
opencl? (
>=sys-devel/llvm-3.6.0:=[${MULTILIB_USEDEP}]
>=sys-devel/clang-3.6.0:=[${MULTILIB_USEDEP}]