summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-09-01 02:53:13 -0400
committerTim Harder <radhermit@gentoo.org>2017-09-01 02:54:07 -0400
commit2e967ba1b9fe67f3c908641d0ee356c5dc6b248b (patch)
treed71f1a2d1f53b7f341e840a3ece00d5ebacf447e
parentapp-misc/evemu: use ltprune instead of eutils (diff)
downloadgentoo-2e967ba1.tar.gz
gentoo-2e967ba1.tar.bz2
gentoo-2e967ba1.zip
app-misc/evemu: remove old
-rw-r--r--app-misc/evemu/Manifest2
-rw-r--r--app-misc/evemu/evemu-2.4.0.ebuild43
-rw-r--r--app-misc/evemu/evemu-2.5.0.ebuild43
3 files changed, 0 insertions, 88 deletions
diff --git a/app-misc/evemu/Manifest b/app-misc/evemu/Manifest
index 54cda68031f7..0e76887248ab 100644
--- a/app-misc/evemu/Manifest
+++ b/app-misc/evemu/Manifest
@@ -1,3 +1 @@
-DIST evemu-2.4.0.tar.xz 505848 SHA256 0706ea5a830203f9cdb30c0e10c8c41d2427128ba9041543a5ae157fa3b4a30e SHA512 e629a0eedb6ce58d3f088b279f45b87117b30b01af07e53dd5515ced7ea15293476fafe9aa9832e6758a6953ad7a462b0fae0a0996181eec327377176cf00c7a WHIRLPOOL ad909f5e074dfdd0d6c9f3660844024f94da587f97cf9181e5ab1232fe077c8df47cca045b598a472bbf6ec776c2cbf313908a800d95a539173770080fb388ce
-DIST evemu-2.5.0.tar.xz 506092 SHA256 541cc138f0215b7d0cd4ad5e6bb1402518ffc5e31294c36bb67b4ff1791bb27f SHA512 7de37aeaa122501783f4b658bd18353a6f413ff57ce1feec71e0eedd21eba3e479ff6ffb79dbb7658a337c824f4575915f13edcfdf8d2ce52a1fdbd41e1610be WHIRLPOOL 094294327d3226918ded20bd5e36d05abe78b3aa46f45bd777ae0442033911cfafd572fb4f92b7509037b4e264e016c0287234d6b16e17e81e9ea1a38c4298c8
DIST evemu-2.6.0.tar.xz 507032 SHA256 ed81dd4552ffeb92c346b47e56b249c67f1cb37d5b31fc073ea0ad4858ae3dcc SHA512 8dd3be18abc6e36a79b91e6099116048e4fd45a96531a5c2773c84618d6ba7089ee8734b51b9309462c393dc7c3a83d87438bcbdcd5876803165a4ea439aff83 WHIRLPOOL a1369b512c15b50a6ad90749cd2b24b488b65b445fa687fa823a1b7654d19fc363d1fd8105f86aa61992a4770137718346c06a1858e9f842891ec0237a85d2fd
diff --git a/app-misc/evemu/evemu-2.4.0.ebuild b/app-misc/evemu/evemu-2.4.0.ebuild
deleted file mode 100644
index 83007cff7385..000000000000
--- a/app-misc/evemu/evemu-2.4.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils python-single-r1
-
-DESCRIPTION="tools and bindings for kernel evdev device emulation, data capture, and replay"
-HOMEPAGE="https://www.freedesktop.org/wiki/Evemu/"
-SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
-
-LICENSE="LGPL-3 GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="python static-libs"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="python? ( ${PYTHON_DEPS} )
- >=dev-libs/libevdev-1.2.99.902"
-DEPEND="app-arch/xz-utils
- ${RDEPEND}"
-
-src_configure() {
- econf \
- $(use_enable static-libs static) \
- $(use_enable python python-bindings)
-}
-
-src_test() {
- if use python ; then
- if [[ ! ${EUID} -eq 0 ]] || has sandbox $FEATURES || has usersandbox $FEATURES ; then
- ewarn "Tests require userpriv, sandbox, and usersandbox to be disabled in FEATURES."
- else
- emake check
- fi
- fi
-}
-
-src_install() {
- default
- prune_libtool_files
-}
diff --git a/app-misc/evemu/evemu-2.5.0.ebuild b/app-misc/evemu/evemu-2.5.0.ebuild
deleted file mode 100644
index 83007cff7385..000000000000
--- a/app-misc/evemu/evemu-2.5.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils python-single-r1
-
-DESCRIPTION="tools and bindings for kernel evdev device emulation, data capture, and replay"
-HOMEPAGE="https://www.freedesktop.org/wiki/Evemu/"
-SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
-
-LICENSE="LGPL-3 GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="python static-libs"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="python? ( ${PYTHON_DEPS} )
- >=dev-libs/libevdev-1.2.99.902"
-DEPEND="app-arch/xz-utils
- ${RDEPEND}"
-
-src_configure() {
- econf \
- $(use_enable static-libs static) \
- $(use_enable python python-bindings)
-}
-
-src_test() {
- if use python ; then
- if [[ ! ${EUID} -eq 0 ]] || has sandbox $FEATURES || has usersandbox $FEATURES ; then
- ewarn "Tests require userpriv, sandbox, and usersandbox to be disabled in FEATURES."
- else
- emake check
- fi
- fi
-}
-
-src_install() {
- default
- prune_libtool_files
-}