summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <william.hubbs@sony.com>2019-03-21 12:56:32 -0500
committerWilliam Hubbs <williamh@gentoo.org>2019-03-21 14:08:37 -0500
commit2e9d5ff47744b9f2e37982085f35a73f884bc90a (patch)
tree1282b1bbaffda4f1d5db4e04daf7aed5f2cb2ed9
parentdev-python/psycopg: 2.7.7 bump (diff)
downloadgentoo-2e9d5ff47744b9f2e37982085f35a73f884bc90a.tar.gz
gentoo-2e9d5ff47744b9f2e37982085f35a73f884bc90a.tar.bz2
gentoo-2e9d5ff47744b9f2e37982085f35a73f884bc90a.zip
dev-python/python-sqlparse: 0.3.0 bump
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: William Hubbs <williamh@gentoo.org>
-rw-r--r--dev-python/python-sqlparse/Manifest1
-rw-r--r--dev-python/python-sqlparse/python-sqlparse-0.3.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/python-sqlparse/Manifest b/dev-python/python-sqlparse/Manifest
index af1f8279d8e8..7760bee3a002 100644
--- a/dev-python/python-sqlparse/Manifest
+++ b/dev-python/python-sqlparse/Manifest
@@ -1,2 +1,3 @@
DIST sqlparse-0.2.3.tar.gz 60742 BLAKE2B 38d3f17d196d3a1d50ea75810b5bd3a890c6f4b12195621d571d62b8c40e2e2d13034deddd95288df37a15daba28153a5ca9221b78bfff1c0e3bc37eddca2dba SHA512 ec654e680f8ce423a89da92c4c74f85e652bebb19e9a40ab0b8067f61803897e49e1e6f8dd1ab454b1ed130974d76b4f973c799264fd4bf8a87f034ba9c44835
DIST sqlparse-0.2.4.tar.gz 61614 BLAKE2B 2462fa5d77ca2c3028aa3539bedc3cb2d7abd35db3c736ffd8abad8626a33174787f0079453ec646739749c8860fce0f1c7d815e6a8485c24b851a40b5bf3b87 SHA512 abea0f084778976f2d1086006eaa88e1fc1d2580654d063b35557a44d9d9727b410a022e8ea06ae3b265f2829d49c48d347dddc61f2e56be9c3d6207104712b2
+DIST sqlparse-0.3.0.tar.gz 64072 BLAKE2B fbee74c7222fa50c5d627959d5c8652dcd85ab5b5b771e3c8375cadc6e009c2fb1adc3c2428e27d769c210e7976c350bfab367cb7aa44dd7b4183ad9722a4ca6 SHA512 596d25f5fa2c797fe5652e36e9633397e7867586ff0959f52d1ff861c16d0e7c73644daf03d74169dd20255e802b7369d4dace0a44a3d94c15bd67faa41df551
diff --git a/dev-python/python-sqlparse/python-sqlparse-0.3.0.ebuild b/dev-python/python-sqlparse/python-sqlparse-0.3.0.ebuild
new file mode 100644
index 000000000000..8d9e4eac466c
--- /dev/null
+++ b/dev-python/python-sqlparse/python-sqlparse-0.3.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+
+inherit distutils-r1
+
+MY_PN="${PN##python-}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A non-validating SQL parser module for Python"
+HOMEPAGE="https://github.com/andialbrecht/sqlparse"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="BSD-2"
+IUSE="doc test"
+
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ )"
+# Required for running tests
+DISTUTILS_IN_SOURCE_BUILD=1
+
+S="${WORKDIR}"/${P#python-}
+
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ if python_is_python3; then
+ 2to3 -w --no-diffs -n tests/ sqlparse/
+ py.test ./tests || die "testsuite failed ${EPYTHON}"
+ else
+ py.test tests || die "testsuite failed under ${EPYTHON}"
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}