summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-08-22 20:28:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-08-22 22:10:59 +0200
commit2e9e331f98c3720fc1302cf5eaf69c0fe1d27b56 (patch)
treef1f352441aee5ca9c61598aa7249429c24119b97
parentdev-libs/kopeninghours: 22.08.0 version bump (diff)
downloadgentoo-2e9e331f98c3720fc1302cf5eaf69c0fe1d27b56.tar.gz
gentoo-2e9e331f98c3720fc1302cf5eaf69c0fe1d27b56.tar.bz2
gentoo-2e9e331f98c3720fc1302cf5eaf69c0fe1d27b56.zip
dev-libs/kosmindoormap: 22.08.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-libs/kosmindoormap/Manifest1
-rw-r--r--dev-libs/kosmindoormap/kosmindoormap-22.08.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/kosmindoormap/Manifest b/dev-libs/kosmindoormap/Manifest
index 24408d6ba90a..565724f00788 100644
--- a/dev-libs/kosmindoormap/Manifest
+++ b/dev-libs/kosmindoormap/Manifest
@@ -1 +1,2 @@
DIST kosmindoormap-22.04.3.tar.xz 351256 BLAKE2B c18ff31d5cd2b5e2d92bed51b6e6e7addf3319381ee3a200b372a6659aa4ac80d01d63898e2d29705374a23608d16463ab2f4daa77179fefa78038f34058e59b SHA512 f272b250142a4ae6275b0234ff3ebbadb1eebe2302d28286de47c230363bfd7f153574fad4a7f2ada3507db80552dce1f0fc49ae9db5427d144ce0bbc3052b5f
+DIST kosmindoormap-22.08.0.tar.xz 356152 BLAKE2B d90100fd3d8aa9fe8643ee91c0a71b9f3c50bcf8309ca0378ec13de2f5ab6b81213a0f9f85978a3eb5f5bce534306f738825c5e3db3c9d93d8436b1ca68069c8 SHA512 cb0e9f315275079d93f46debcde384aa6d96bf8a3aaadc774233b3ff7471b00cb0ad3b3b462bd55aa2424752612f629ca64061cc2492673aecf2fa469305101e
diff --git a/dev-libs/kosmindoormap/kosmindoormap-22.08.0.ebuild b/dev-libs/kosmindoormap/kosmindoormap-22.08.0.ebuild
new file mode 100644
index 000000000000..8580f3dd2f41
--- /dev/null
+++ b/dev-libs/kosmindoormap/kosmindoormap-22.08.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.96.0
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Data Model and Extraction System for Travel Reservation information"
+HOMEPAGE="https://invent.kde.org/libraries/kosmindoormap"
+
+LICENSE="LGPL-2+"
+SLOT="5"
+KEYWORDS="~amd64"
+IUSE="+openinghours"
+
+COMMON_DEPEND="
+ >=dev-libs/kpublictransport-${PVCUT}:5
+ dev-libs/protobuf:=
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ sys-libs/zlib
+ openinghours? ( >=dev-libs/kopeninghours-${PVCUT}:5 )
+"
+DEPEND="${COMMON_DEPEND}
+ test? ( >=dev-qt/qtwidgets-${QTMIN}:5 )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_OsmTools=ON # we have no use for it
+ $(cmake_use_find_package openinghours KOpeningHours)
+ )
+ ecm_src_configure
+}