summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-12 22:15:13 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-12 23:02:02 +0200
commit2ea1ccc47b5d9657cc5f8bfa71092aec65443e64 (patch)
tree1e1dc47d6b6347db34ea32672c00324d1c23b58d
parentdev-python/python-email-validator: Bump to 1.1.3 (diff)
downloadgentoo-2ea1ccc4.tar.gz
gentoo-2ea1ccc4.tar.bz2
gentoo-2ea1ccc4.zip
dev-python/humanize: Bump to 3.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/humanize/Manifest1
-rw-r--r--dev-python/humanize/humanize-3.8.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/humanize/Manifest b/dev-python/humanize/Manifest
index 0536f2b16c55..27aa14e1772e 100644
--- a/dev-python/humanize/Manifest
+++ b/dev-python/humanize/Manifest
@@ -1,3 +1,4 @@
DIST humanize-3.5.0.tar.gz 56651 BLAKE2B 05095fbdf7c55258bf3d01c73f47bf913e1fda3e6d8a2fcf666f4d70cfd6e437071140716b9f5b6a31c02c06da1d2df6f80d5d021c279d4f97f756f41f3c3bb3 SHA512 ca04d79533b08f1549cd530fec35352696b314d6d667476bf5506a482a4ff379fe6ae021a1f338aa6837877a90e57ce032cdc671b68be34dd52e0e41aad10170
DIST humanize-3.7.0.tar.gz 44002 BLAKE2B ec253c07a38c83d67038836998a7159afe7d1f3e1f0f5ea0f946f987e18bf4943d7dd48e2e156009627e1bda2140017bf99df072671008a6e1daad704b693292 SHA512 e501cdb4dcb603601624f5df9a04a256669f06ac594d8a3a0c83543d1d8503bfcf4d7198ff87827e2c60dd63897c23b722be7497179c49a9f9b05d07289de4be
DIST humanize-3.7.1.tar.gz 61846 BLAKE2B 6ed6e35dc15ef08a88cd15211212cbd4194363889ff0dbe4e53d76adb248da948d688e4eddf5a93548497b1e1e02145431e1c157fd26288fc27f2b9b7b2c80b7 SHA512 152ee6030de83be34bdb40908427ca4f1461191ce417faef273b070a1d347a43f4a44182cd0fa79b8935c07d97679205285bbd6fa43352d2d9cada53df5f112f
+DIST humanize-3.8.0.tar.gz 64298 BLAKE2B ba367054f66351b7b48bed69ab4ba63251dbdd6bb56c21cbd8d7846401d4a2428f6e069a0219b5a24bfde173d6ed2ef3116f01551137b4c0c1eddd8c9d6fc87b SHA512 8301f461c60fd990e50a24aef714d78a3b42fb82d792ac01b088e05b6bf765dfa34e2257c1a75e3da279db3b8d837bd6434398f33578c946fa17dc1a45122f75
diff --git a/dev-python/humanize/humanize-3.8.0.ebuild b/dev-python/humanize/humanize-3.8.0.ebuild
new file mode 100644
index 000000000000..b6c00705226e
--- /dev/null
+++ b/dev-python/humanize/humanize-3.8.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Common humanization utilities"
+HOMEPAGE="https://github.com/jmoiron/humanize/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests --install pytest