summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-10-23 11:29:11 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-10-23 11:52:46 +0200
commit2effe7a41c165e750ec672002487e794c734ed8a (patch)
treebc0cfba5314602fae74686c5174bd1845e2c131d
parentx11-apps/copyq: [QA] pkgmove to x11-misc/copyq (diff)
downloadgentoo-2effe7a41c165e750ec672002487e794c734ed8a.tar.gz
gentoo-2effe7a41c165e750ec672002487e794c734ed8a.tar.bz2
gentoo-2effe7a41c165e750ec672002487e794c734ed8a.zip
x11-misc/copyq: 3.13.0 version bump, drop IUSE=webkit
Closes: https://bugs.gentoo.org/727326 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--x11-misc/copyq/Manifest1
-rw-r--r--x11-misc/copyq/copyq-3.13.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/x11-misc/copyq/Manifest b/x11-misc/copyq/Manifest
index 86696b31c9d5..a32af6f0898f 100644
--- a/x11-misc/copyq/Manifest
+++ b/x11-misc/copyq/Manifest
@@ -1 +1,2 @@
DIST CopyQ-3.10.0.tar.gz 2832904 BLAKE2B 78866a3ecbd1ed4d1ab06db552ef517234c1354609ef2bc18f8c4d8fa22342c7479a5bde79b9333f896dee4fe18543e47657c780b821f45121e0413c597b45aa SHA512 6cae338a144d7f92850ce88c991ed99222613c57540ced49dab719e43af884bbd9d15e6e8f074c6af94b0ac2ecd1b355eff8b83ec99f688c0f93fa19f253d653
+DIST copyq-3.13.0.tar.gz 2917941 BLAKE2B e8fc963e6a773ae70ca5a39f9ea55a98de5c5d129b845d0da9ed08ffec65d88ed8b5dd138dea11a33d563b899f0497929ed3c40d418574e50c2a1fbbd7b1a9f6 SHA512 898d4501002202849f0b5302d7315e8c539f8b0f8d5198641b3d3a647839581841e2ef1e2519c690d3cc95f85fdc921c979f2879348184de42767d31e081c307
diff --git a/x11-misc/copyq/copyq-3.13.0.ebuild b/x11-misc/copyq/copyq-3.13.0.ebuild
new file mode 100644
index 000000000000..2f1b7720f7a3
--- /dev/null
+++ b/x11-misc/copyq/copyq-3.13.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Clipboard manager with advanced features"
+HOMEPAGE="https://github.com/hluk/CopyQ"
+SRC_URI="https://github.com/hluk/CopyQ/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtscript:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ x11-libs/libXfixes
+ x11-libs/libXtst
+"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:5 )"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+
+S="${WORKDIR}/CopyQ-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DPLUGIN_INSTALL_PREFIX="/usr/$(get_libdir)/${PN}/plugins"
+ -DWITH_TESTS=$(usex test)
+ -DWITH_WEBKIT=OFF
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}