summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2024-03-24 18:07:47 +0800
committerBenda Xu <heroxbd@gentoo.org>2024-03-24 21:37:54 +0800
commit2f155078f765ad90a8ba456daf8198fd800fee5d (patch)
treea0e862f5dd3b7876f009a5ac2ec6eee48b8d040f
parentdev-python/jupyter-ydoc: revive with version 2.0.1. (diff)
downloadgentoo-2f155078f765ad90a8ba456daf8198fd800fee5d.tar.gz
gentoo-2f155078f765ad90a8ba456daf8198fd800fee5d.tar.bz2
gentoo-2f155078f765ad90a8ba456daf8198fd800fee5d.zip
dev-python/jupyter-collaboration: new package, add 2.0.5
This is renamed from the previous jupyter-server-ydoc. profiles/arch/amd64/x32: mask jupyter-collaboration on x32. Reference: https://jupyterlab.readthedocs.io/en/latest/user/rtc.html Bug: https://bugs.gentoo.org/915824 Signed-off-by: Benda Xu <heroxbd@gentoo.org>
-rw-r--r--dev-python/jupyter-collaboration/Manifest1
-rw-r--r--dev-python/jupyter-collaboration/files/jupyter-collaboration-2.0.5-no-node-for-version.patch42
-rw-r--r--dev-python/jupyter-collaboration/jupyter-collaboration-2.0.5.ebuild42
-rw-r--r--dev-python/jupyter-collaboration/metadata.xml12
-rw-r--r--profiles/arch/amd64/x32/package.mask1
5 files changed, 98 insertions, 0 deletions
diff --git a/dev-python/jupyter-collaboration/Manifest b/dev-python/jupyter-collaboration/Manifest
new file mode 100644
index 000000000000..a33beac6f32c
--- /dev/null
+++ b/dev-python/jupyter-collaboration/Manifest
@@ -0,0 +1 @@
+DIST jupyter_collaboration-2.0.5.tar.gz 4806126 BLAKE2B 5df0d7f782f9574e9f48ea805786b8e85a71fa2938189eef31e0d674e7c173f14d388952e33529f6666cecd9754191caaaeacea30cb090452d8545a19e3951d3 SHA512 e1375bc0559a06596e565cfe3b9b0f9a83a95a64d8a474cf7065172f9df5b84faa4f1966867bb475610df4662205146bb5720005601bafe77790e541681a3e8d
diff --git a/dev-python/jupyter-collaboration/files/jupyter-collaboration-2.0.5-no-node-for-version.patch b/dev-python/jupyter-collaboration/files/jupyter-collaboration-2.0.5-no-node-for-version.patch
new file mode 100644
index 000000000000..665a8b91efa8
--- /dev/null
+++ b/dev-python/jupyter-collaboration/files/jupyter-collaboration-2.0.5-no-node-for-version.patch
@@ -0,0 +1,42 @@
+Index: jupyter_collaboration-2.0.3/pyproject.toml
+===================================================================
+--- jupyter_collaboration-2.0.3.orig/pyproject.toml
++++ jupyter_collaboration-2.0.3/pyproject.toml
+@@ -3,10 +3,11 @@
+
+ [build-system]
+ build-backend = "hatchling.build"
+-requires = ["hatchling>=1.4.0", "hatch-nodejs-version", "jupyterlab>=4.0.0"]
++requires = ["hatchling>=1.4.0", "jupyterlab>=4.0.0"]
+
+ [project]
+ name = "jupyter_collaboration"
++version = "2.0.5"
+ readme = "README.md"
+ license = { file = "LICENSE" }
+ requires-python = ">=3.8"
+@@ -34,7 +35,7 @@ dependencies = [
+ "jupyter_server_fileid>=0.7.0,<1",
+ "jsonschema>=4.18.0"
+ ]
+-dynamic = ["version", "description", "authors", "urls", "keywords"]
++dynamic = ["description", "authors", "urls", "keywords"]
+
+ [project.optional-dependencies]
+ dev = [
+@@ -63,15 +64,9 @@ line-length = 100
+ [tool.isort]
+ profile = "black"
+
+-[tool.hatch.version]
+-source = "nodejs"
+-
+ [tool.hatch.build.hooks.version]
+ path = "jupyter_collaboration/_version.py"
+
+-[tool.hatch.metadata.hooks.nodejs]
+-fields = ["description", "authors", "urls"]
+-
+ [tool.hatch.build.targets.sdist]
+ artifacts = ["/jupyter_collaboration/labextension"]
+ exclude = ["/.github", "/binder", "node_modules"]
diff --git a/dev-python/jupyter-collaboration/jupyter-collaboration-2.0.5.ebuild b/dev-python/jupyter-collaboration/jupyter-collaboration-2.0.5.ebuild
new file mode 100644
index 000000000000..d023ac01306b
--- /dev/null
+++ b/dev-python/jupyter-collaboration/jupyter-collaboration-2.0.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_1{1..2} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="JupyterLab Extension enabling Real-Time Collaboration"
+HOMEPAGE="https://github.com/jupyterlab/jupyter-collaboration"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+RDEPEND="dev-python/pycrdt-websocket[${PYTHON_USEDEP}]
+ >=dev-python/jupyterlab-4[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-ydoc-2[${PYTHON_USEDEP}]
+ dev-python/jupyter-server-fileid[${PYTHON_USEDEP}]
+"
+BDEPEND="dev-python/hatch-jupyter-builder[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-jupyter[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.0.5-no-node-for-version.patch"
+)
+
+distutils_enable_tests pytest
+
+src_install() {
+ distutils-r1_src_install
+
+ # hatchling cannot install into /etc while specifying prefix as /usr
+ mv -v "${ED}"{/usr,}/etc || die
+}
diff --git a/dev-python/jupyter-collaboration/metadata.xml b/dev-python/jupyter-collaboration/metadata.xml
new file mode 100644
index 000000000000..3fb7c745dec1
--- /dev/null
+++ b/dev-python/jupyter-collaboration/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">jupyter-collaboration</remote-id>
+ <remote-id type="github">jupyterlab/jupyter-collaboration</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/profiles/arch/amd64/x32/package.mask b/profiles/arch/amd64/x32/package.mask
index ee3f8e2db1a2..e45b51f2efad 100644
--- a/profiles/arch/amd64/x32/package.mask
+++ b/profiles/arch/amd64/x32/package.mask
@@ -35,6 +35,7 @@ dev-python/jupyterlab
dev-python/jupyterlab-lsp
dev-python/jupyter-server-proxy
sci-misc/jupyterlab-desktop-bin
+dev-python/jupyter-collaboration
dev-python/plotly
dev-python/plotly-geo
dev-python/chart-studio