summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-14 22:04:03 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-14 22:37:42 +0100
commit2f1e65ed8195048060bcdbd7d44037ae2f54ac54 (patch)
treebe3dd64a8b22e050b5c6e510efe635e422638347
parentdev-python/pyfakefs: Bump to 4.5.5 (diff)
downloadgentoo-2f1e65ed8195048060bcdbd7d44037ae2f54ac54.tar.gz
gentoo-2f1e65ed8195048060bcdbd7d44037ae2f54ac54.tar.bz2
gentoo-2f1e65ed8195048060bcdbd7d44037ae2f54ac54.zip
dev-python/jc: Bump to 1.18.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/jc/Manifest1
-rw-r--r--dev-python/jc/jc-1.18.3.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/jc/Manifest b/dev-python/jc/Manifest
index 478d5fa38237..b9c7b674b7e6 100644
--- a/dev-python/jc/Manifest
+++ b/dev-python/jc/Manifest
@@ -1,3 +1,4 @@
DIST jc-1.17.7.tar.gz 3922848 BLAKE2B e075e5e2c7bd06d7c4310a2cb94b1ddd55014d9d8a920c100fcba01735188a7a9ed221224cc73e62efab02a9feb8d1f208a30964e41111063f1147299f098ce6 SHA512 be565377f3f776b387e4a8ff6bc07ac39c93bcf1a21e71cf96dd3474f459e07f050fd30b0b9281331a39c361155463b63c5a61f4271885126406029b5f9546a0
DIST jc-1.18.1.tar.gz 3927394 BLAKE2B f87744e2cfdda10e6d2b1ea021f304e533ab1838de37f09b534e8ed1cf522d6267c96ac22d9ab665fdd593d27adcfa6da34f2f2471bae783585745882796ff8d SHA512 00fb9bfd2ebf9419c866ed56113310f3917e5dbbe538b0d48f5e66979773108f430168186fb350ed9494344f1ceb80e0bcef51344994b78e852b5c6305e9c474
DIST jc-1.18.2.tar.gz 3928302 BLAKE2B 5deb67c56d3fc32728da6e67d7941c8ba01482c1ead86c82f68ed49c8aa53de8e88a77c3840db1f4d9c4d00ea5c96fdb9f7631d99f1dd9a288a41e2e9d50b797 SHA512 f425cc225fd4f993bb0a3c5065f0e90894e7330976dc4bfae08acd4559d0cad5a4cd14d93976814ea03f853ec0faf11bfc1c3b6b8b9d7a61071398d628ab57dc
+DIST jc-1.18.3.tar.gz 3970152 BLAKE2B bd37c2f4128005b39c4fd6b44664d2443f77830ca3158f0b4bb7133527e2543657f3d9654c8d845ada55c2940fc18cc7232117d3e298e3bfc62188250ee1b1c6 SHA512 8076668caaef2559537f828b45d0624f2a2ed35893e1c5af82671f3d97e1f71ebc22817f4036a0d60af183a5b3e717854672b2cfc65f776532ea8ca99ddfec35
diff --git a/dev-python/jc/jc-1.18.3.ebuild b/dev-python/jc/jc-1.18.3.ebuild
new file mode 100644
index 000000000000..f4014eac3167
--- /dev/null
+++ b/dev-python/jc/jc-1.18.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Converts the output of popular command-line tools and file-types to JSON"
+HOMEPAGE="https://github.com/kellyjonbrazil/jc"
+SRC_URI="
+ https://github.com/kellyjonbrazil/jc/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+ dev-python/xmltodict[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest