summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-08 08:31:22 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-08 10:25:59 +0200
commit2f59c125c3e9a50c6dcc61a71c78b98dd1c3574f (patch)
tree173e5efa53a46410179959a46ea087ffb208eb33
parentsys-devel/clang-runtime: Bump to 10.0.1-rc4 (diff)
downloadgentoo-2f59c125c3e9a50c6dcc61a71c78b98dd1c3574f.tar.gz
gentoo-2f59c125c3e9a50c6dcc61a71c78b98dd1c3574f.tar.bz2
gentoo-2f59c125c3e9a50c6dcc61a71c78b98dd1c3574f.zip
sci-libs/scipy: Bump to 1.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sci-libs/scipy/Manifest3
-rw-r--r--sci-libs/scipy/scipy-1.5.1.ebuild154
2 files changed, 157 insertions, 0 deletions
diff --git a/sci-libs/scipy/Manifest b/sci-libs/scipy/Manifest
index 86ad48b6cf05..44754c74cdbb 100644
--- a/sci-libs/scipy/Manifest
+++ b/sci-libs/scipy/Manifest
@@ -7,3 +7,6 @@ DIST scipy-1.4.1.tar.gz 24555206 BLAKE2B e35f6234404839cbd24d463c8cc2f1ea66aed91
DIST scipy-1.5.0-html.zip 23579592 BLAKE2B 6e35a881967d38db67278d6990fbb1912238bca05c7064585aaaf849861371680c2cd5d3e9a150301c29984aa12db0eeebf5f23cb7d2a438edb28fed9654ac79 SHA512 a1dcf9c2d003b1f722a216c8bf0fda7022765c01505343e86da64ec9a4dbda4eb7da74ad09147e5b79e610f090740d19bda6017d6f894f2566547a42e8aa97b3
DIST scipy-1.5.0-ref.pdf 33694300 BLAKE2B a7701cdfd8f6da71b59efcefca5c080426b175976429cb64d47f05f42795fea3abb6764c2e2d1807f215c9e00ccd5b2de254f1c68269b266492dfaf76f887972 SHA512 3208ab84421fbec0597931c6050666e9da7d21c6e73a685f084e9570a39539e9c2e5f7fbdfe27951b2ba8e51a1bc42b06ddd6c906a6a13c81a34a16dc0672dda
DIST scipy-1.5.0.tar.gz 25573194 BLAKE2B f505e5f0627687aeefe0af0886b03eead9f6426f17bca21a3f73cc0d4957ac574e0123b86424ccf0d5f8f4a963b707a1443ddcd6e149f2a4e747daa55b1be95c SHA512 4c981a3125a88593cbc5a17417022a5db8f6ccb4c1c24e78afeb9bb26428b81d2d0fe9965caa418753b1bbbda2fa30533fa1307aac6ab168458d68f7b46049be
+DIST scipy-1.5.1-html.zip 23582280 BLAKE2B 97b256bc7367836f35ce7e0ac47436dd72c1afe249dea1a2f437ea883e74ecb8f5bbe22e20bb804aac66b86fb35e8b4f0e329c44d9d601318ef1accc82e8e850 SHA512 eb0c7736d2bdc9f45926d19f4a22e1168d0f06e21b338cd7e7884af79c7634885350c510251d4cd1629b2a294003e93f8e71bafd8ec64c1aea4d4174c3946597
+DIST scipy-1.5.1-ref.pdf 33698325 BLAKE2B 6ff0d13474acf2960352580765c86ef54faa9bb616b4b8097665fa3b8a3a6033acb524d5bb76757b23d0ea9550b556293509a91e5cbeb7b0a388ea75d1bec29b SHA512 c0fbebb5dec19aebe7783507ccebf28134227096caad915e1f28f963386a07b1246fa624e4680691809c5ba31a09d3dd6e4f27f9e86f5985f8a7eecb1eea82d3
+DIST scipy-1.5.1.tar.gz 25575560 BLAKE2B e431a54f1810590b75d0f115bdbcd3c561d0d918664d91654fa4f2583d4d2807deae36b3293be0a5add650fb5d99f744e1d893d369f6053741d863e2826dcc3c SHA512 d46abaaa52e5521d8f3f6d79f58c8473a8649faa01e93d250d2ee19d5778e31c13aaa855bd8f059ddc1424ae13001f15a41f240fa6b0acf3ffd911ea30da1040
diff --git a/sci-libs/scipy/scipy-1.5.1.ebuild b/sci-libs/scipy/scipy-1.5.1.ebuild
new file mode 100644
index 000000000000..21948a8eb2c5
--- /dev/null
+++ b/sci-libs/scipy/scipy-1.5.1.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{6..9} )
+PYTHON_REQ_USE="threads(+)"
+
+DOC_PV=${PV}
+
+inherit fortran-2 distutils-r1 flag-o-matic multiprocessing toolchain-funcs
+
+DESCRIPTION="Scientific algorithms library for Python"
+HOMEPAGE="https://www.scipy.org/"
+SRC_URI="
+ mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz
+ doc? (
+ https://docs.scipy.org/doc/${PN}-${DOC_PV}/${PN}-html-${PV}.zip -> ${PN}-${DOC_PV}-html.zip
+ https://docs.scipy.org/doc/${PN}-${DOC_PV}/${PN}-ref-${PV}.pdf -> ${PN}-${DOC_PV}-ref.pdf
+ )"
+
+LICENSE="BSD LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc sparse test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="
+ >=dev-python/numpy-1.10[lapack,${PYTHON_USEDEP}]
+ sci-libs/arpack:0=
+ virtual/cblas
+ virtual/lapack
+ sparse? ( sci-libs/umfpack:0= )"
+DEPEND="${CDEPEND}
+ dev-lang/swig
+ >=dev-python/cython-0.29.13[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-36[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ doc? ( app-arch/unzip )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+RDEPEND="${CDEPEND}
+ dev-python/pillow[${PYTHON_USEDEP}]"
+
+DOCS=( HACKING.rst.txt THANKS.txt )
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+src_unpack() {
+ default
+ if use doc; then
+ unzip -qo "${DISTDIR}"/${PN}-${DOC_PV}-html.zip -d html || die
+ fi
+}
+
+pc_incdir() {
+ $(tc-getPKG_CONFIG) --cflags-only-I $@ | \
+ sed -e 's/^-I//' -e 's/[ ]*-I/:/g' -e 's/[ ]*$//' -e 's|^:||'
+}
+
+pc_libdir() {
+ $(tc-getPKG_CONFIG) --libs-only-L $@ | \
+ sed -e 's/^-L//' -e 's/[ ]*-L/:/g' -e 's/[ ]*$//' -e 's|^:||'
+}
+
+pc_libs() {
+ $(tc-getPKG_CONFIG) --libs-only-l $@ | \
+ sed -e 's/[ ]-l*\(pthread\|m\)\([ ]\|$\)//g' \
+ -e 's/^-l//' -e 's/[ ]*-l/,/g' -e 's/[ ]*$//' \
+ | tr ',' '\n' | sort -u | tr '\n' ',' | sed -e 's|,$||'
+}
+
+python_prepare_all() {
+ # scipy automatically detects libraries by default
+ export {FFTW,FFTW3,UMFPACK}=None
+ use sparse && unset UMFPACK
+ # the missing symbols are in -lpythonX.Y, but since the version can
+ # differ, we just introduce the same scaryness as on Linux/ELF
+ [[ ${CHOST} == *-darwin* ]] \
+ && append-ldflags -bundle "-undefined dynamic_lookup" \
+ || append-ldflags -shared
+ [[ -z ${FC} ]] && export FC="$(tc-getFC)"
+ # hack to force F77 to be FC until bug #278772 is fixed
+ [[ -z ${F77} ]] && export F77="$(tc-getFC)"
+ export F90="${FC}"
+ export SCIPY_FCONFIG="config_fc --noopt --noarch"
+ append-fflags -fPIC
+
+ local libdir="${EPREFIX}"/usr/$(get_libdir)
+ cat >> site.cfg <<-EOF || die
+ [blas]
+ include_dirs = $(pc_incdir cblas)
+ library_dirs = $(pc_libdir cblas blas):${libdir}
+ blas_libs = $(pc_libs cblas blas)
+ [lapack]
+ library_dirs = $(pc_libdir lapack):${libdir}
+ lapack_libs = $(pc_libs lapack)
+ EOF
+ cat >> setup.cfg <<-EOF || die
+ [options]
+ zip_safe = False
+ EOF
+
+ # Drop hashes to force rebuild of cython based .c code
+ rm cythonize.dat || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ # bug 721860
+ test-flag-FC -fallow-argument-mismatch &&
+ append-fflags -fallow-argument-mismatch
+}
+
+python_compile() {
+ # FIXME: parallel python building fails, bug #614464
+ export MAKEOPTS=-j1
+
+ ${EPYTHON} tools/cythonize.py || die
+ distutils-r1_python_compile \
+ ${SCIPY_FCONFIG}
+}
+
+python_test() {
+ # fails with bdist_egg. should it be fixed in distutils-r1 eclass?
+ distutils_install_for_testing ${SCIPY_FCONFIG}
+ cd "${TEST_DIR}/lib" || die "no ${TEST_DIR} available"
+ PYTHONPATH=. "${EPYTHON}" -c "
+import scipy, sys
+r = scipy.test('fast', verbose=2)
+sys.exit(0 if r else 1)" || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && \
+ local DOCS=( "${DISTDIR}"/${PN}-${DOC_PV}-ref.pdf ) \
+ local HTML_DOCS=( "${WORKDIR}"/html/. )
+ distutils-r1_python_install_all
+}
+
+python_install() {
+ distutils-r1_python_install ${SCIPY_FCONFIG}
+ python_optimize
+}
+
+pkg_postinst() {
+ elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
+ elog "to your prefered image viewer. Example:"
+ elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
+}