summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-25 23:32:55 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-25 23:58:43 +0200
commit2f670f844c7f93d1004cc3513ac2ecf8819053f1 (patch)
tree13163de7e337350eaf5f3af7a729eff3f424e932
parentdev-python/aiorpcX: Bump to 0.22.0 (diff)
downloadgentoo-2f670f84.tar.gz
gentoo-2f670f84.tar.bz2
gentoo-2f670f84.zip
dev-python/Rx: Bump to 3.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/Rx/Manifest1
-rw-r--r--dev-python/Rx/Rx-3.2.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/Rx/Manifest b/dev-python/Rx/Manifest
index c65dbaf4664f..3fe4869ea4ee 100644
--- a/dev-python/Rx/Manifest
+++ b/dev-python/Rx/Manifest
@@ -1 +1,2 @@
DIST Rx-3.1.0.tar.gz 890293 BLAKE2B 268f6df5450d1235d50f9aee5cd43fe6e229acf7b2ddab5f1f97e80594aeff7beaa280fe272ac9cc8b80dc6874f4bb76e438e94c09712f2c37e72d8d40f9f283 SHA512 1d9f6639ef08dc991326b95fcbf0978adea55b35acab653fc16bd94ccf2ad3a1515e8cb4e8d2ff38d7a506306e310394339a8651a2a02fa22bfb7f17d86297f1
+DIST RxPY-3.2.0.tar.gz 891490 BLAKE2B 9d4e72c20544f1c607fa28963193ca88d7d6f63c0e4a3faa4e3aafba6cce5bb0c1b99ca7a8fb62052adc3dc02b7ca71d4c190704f18819fbb2598a38b2ce86da SHA512 08a53344ea374b025e51ebf3a7de5ea4e83c7062d0c9a3370b795a56156c8aa068f2b3415f6e5e9e2424a11bcef53a412fd0667afb0016b58b7d2a741ea1007a
diff --git a/dev-python/Rx/Rx-3.2.0.ebuild b/dev-python/Rx/Rx-3.2.0.ebuild
new file mode 100644
index 000000000000..d7dc1233b7a3
--- /dev/null
+++ b/dev-python/Rx/Rx-3.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 virtualx
+
+MY_P="RxPY-${PV}"
+DESCRIPTION="Reactive Extensions for Python"
+HOMEPAGE="http://reactivex.io/"
+SRC_URI="
+ https://github.com/ReactiveX/RxPY/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}