summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-21 01:20:40 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-21 01:26:30 -0400
commit2f7f8c3225a688f3bb17b43a1dec4a007016fdc7 (patch)
tree2fa2bfcf2b8935abba244f39ca6cabe78d0b5c7c
parentx11-terms/kitty-shell-integration: add 0.33.1 (diff)
downloadgentoo-2f7f8c3225a688f3bb17b43a1dec4a007016fdc7.tar.gz
gentoo-2f7f8c3225a688f3bb17b43a1dec4a007016fdc7.tar.bz2
gentoo-2f7f8c3225a688f3bb17b43a1dec4a007016fdc7.zip
x11-terms/kitty-terminfo: add 0.33.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-terms/kitty-terminfo/Manifest1
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.33.1.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
index 27e47a0b7df1..a057acc12417 100644
--- a/x11-terms/kitty-terminfo/Manifest
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -1,2 +1,3 @@
DIST kitty-0.32.2.tar.xz 8103024 BLAKE2B 637449eb655973700493f725846263bfba193729725b6f14490fc44872e191c5e47b272bc3955b5ca47d400a497931be0749d338354ae8a5402fd867f7b941d3 SHA512 245d399366c0b2174bb80d557c08edf49e96a034a3cf33d2027180ef418581cc9bea2566d9ead9f96094bdc01655aeddd251b07b1bc444e7af59c864eb2bcd01
DIST kitty-0.33.0.tar.xz 8170952 BLAKE2B d98c1070d53b43dacc0aeefa6b0fc46a51528b196b09e875406f30eceddd65256090b6efb2b1b24f485b32db6d36483a9dc725934ad0327412e789e2f01a3574 SHA512 5dad29e7ff0f83dd14138fd32ee3d556214251a5617ef9bd0c8a8b4032e26cf8973752d0b4221e06afd745ae4a12967fc1194f3d053b0e8451cb7ca97360fa35
+DIST kitty-0.33.1.tar.xz 8166164 BLAKE2B 6592ae99f3e05bda5367186096804175f00f21770e7112bf45fa968d161e70d2fdcf956214e29e048e6973ee14457f5eaca753a761824f1c104ba32552122e33 SHA512 5fa2421baf9fac41d4a8ff89bb5e44d1820012e8c960e25980d597dcebbb44ffa97c03818e8a91015691321eedb9d9f53139a97cbb6bd673053fbfd73c77739b
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.33.1.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.33.1.ebuild
new file mode 100644
index 000000000000..b5c7cbc40759
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.33.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}