summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-19 18:28:55 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-19 18:29:11 +0200
commit2f801b0ec4408c88e6e1d6460879bce097eb9acb (patch)
treefa8bb3a60c5f6fe5e479a73a335980077df95ebc
parentdev-python/webob: Version Bump (diff)
downloadgentoo-2f801b0ec4408c88e6e1d6460879bce097eb9acb.tar.gz
gentoo-2f801b0ec4408c88e6e1d6460879bce097eb9acb.tar.bz2
gentoo-2f801b0ec4408c88e6e1d6460879bce097eb9acb.zip
dev-python/mpi4py: Version Bump
fixes Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=554058 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/mpi4py/Manifest1
-rw-r--r--dev-python/mpi4py/mpi4py-1.3.1.ebuild4
-rw-r--r--dev-python/mpi4py/mpi4py-2.0.0.ebuild48
3 files changed, 51 insertions, 2 deletions
diff --git a/dev-python/mpi4py/Manifest b/dev-python/mpi4py/Manifest
index db920f5b1d0c..2031eec7cd02 100644
--- a/dev-python/mpi4py/Manifest
+++ b/dev-python/mpi4py/Manifest
@@ -1 +1,2 @@
DIST mpi4py-1.3.1.tar.gz 1046580 SHA256 e7bd2044aaac5a6ea87a87b2ecc73b310bb6efe5026031e33067ea3c2efc3507 SHA512 15e81f2a1e6f6af7a54f0e8ec43ddf36cc565b7fe9e3dd35603c9d128199c5acd1584757ffca999c8826c0bbccf371175d40a7a24c85d3369efd77da5b3b603f WHIRLPOOL e32fef50c8cd8f866e40fb29f90775736cf0ea31c8a3fc4d460cded8b2056bae0c8d847b304c3222d3e5ffc913ca5cc722425e496d35bf41624f9b5ccdf3ead2
+DIST mpi4py-2.0.0.tar.gz 1279957 SHA256 6543a05851a7aa1e6d165e673d422ba24e45c41e4221f0993fe1e5924a00cb81 SHA512 6459b482db782fea1a80499774ebfeb09c828b6c3f1805a0ca306f26f3ebcac52ad1c83bb97a98a01b518b6a6c887f6b99dbda9c37381a5ce05ddff0edb16d81 WHIRLPOOL 1b85699303a813cc35118464c80dffe798eb02dd3248c0b61937236f2f6cea533283a443f8a52298d888584e13e013601260b68552528d1b9b6f25bcccb990e7
diff --git a/dev-python/mpi4py/mpi4py-1.3.1.ebuild b/dev-python/mpi4py/mpi4py-1.3.1.ebuild
index 10b644f216d9..5a1359b7d6fb 100644
--- a/dev-python/mpi4py/mpi4py-1.3.1.ebuild
+++ b/dev-python/mpi4py/mpi4py-1.3.1.ebuild
@@ -9,8 +9,8 @@ PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1
DESCRIPTION="Message Passing Interface for Python"
-HOMEPAGE="https://code.google.com/p/mpi4py/ https://pypi.python.org/pypi/mpi4py"
-SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+HOMEPAGE="https://bitbucket.org/mpi4py/ https://pypi.python.org/pypi/mpi4py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
diff --git a/dev-python/mpi4py/mpi4py-2.0.0.ebuild b/dev-python/mpi4py/mpi4py-2.0.0.ebuild
new file mode 100644
index 000000000000..42b927eaf1df
--- /dev/null
+++ b/dev-python/mpi4py/mpi4py-2.0.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Message Passing Interface for Python"
+HOMEPAGE="https://bitbucket.org/mpi4py/ https://pypi.python.org/pypi/mpi4py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="virtual/mpi"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}]
+ virtual/mpi[romio] )"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # not needed on install
+ rm -r docs/source || die
+ distutils-r1_python_prepare_all
+}
+
+src_compile() {
+ export FAKEROOTKEY=1
+ distutils-r1_src_compile
+}
+
+python_test() {
+ echo "Beginning test phase"
+ pushd "${BUILD_DIR}"/../ &> /dev/null
+ mpiexec -n 2 "${PYTHON}" ./test/runtests.py -v || die "Testsuite failed under ${EPYTHON}"
+ popd &> /dev/null
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ use examples && local EXAMPLES=( demo/. )
+ distutils-r1_python_install_all
+}