summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-12 00:54:18 -0400
committerSam James <sam@gentoo.org>2024-03-12 05:15:40 +0000
commit2f8c57b46ad5450a60adadafdf189f0631500857 (patch)
tree929debde62542c035b1916d721acafff73c59c9a
parentmedia-libs/devil: mark as LTO-unsafe, strict-aliasing unsafe (diff)
downloadgentoo-2f8c57b46ad5450a60adadafdf189f0631500857.tar.gz
gentoo-2f8c57b46ad5450a60adadafdf189f0631500857.tar.bz2
gentoo-2f8c57b46ad5450a60adadafdf189f0631500857.zip
media-gfx/flameshot: mark as LTO-unsafe, strict-aliasing unsafe
Closes: https://bugs.gentoo.org/859613 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-gfx/flameshot/flameshot-12.1.0-r2.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/media-gfx/flameshot/flameshot-12.1.0-r2.ebuild b/media-gfx/flameshot/flameshot-12.1.0-r2.ebuild
index c24b2ab6ac05..b01a0e3e9fc2 100644
--- a/media-gfx/flameshot/flameshot-12.1.0-r2.ebuild
+++ b/media-gfx/flameshot/flameshot-12.1.0-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2021-2023 Gentoo Authors
+# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit cmake xdg
+inherit cmake flag-o-matic xdg
DESCRIPTION="Powerful yet simple to use screenshot software"
HOMEPAGE="https://flameshot.org https://github.com/flameshot-org/flameshot"
@@ -37,6 +37,14 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/859613
+ # https://github.com/flameshot-org/flameshot/issues/3531
+ #
+ # Do not trust with LTO either
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local mycmakeargs=(
-DUSE_EXTERNAL_SINGLEAPPLICATION=1
-DENABLE_CACHE=0