summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-19 07:14:41 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-19 08:02:28 +0200
commit2f9bac83cc23ff73f0271e3c83f3f683c4718806 (patch)
treeeb0fb45710b412bcb797ca115339e1015379e2c5
parentdev-python/types-setuptools: Bump to 69.5.0.20240519 (diff)
downloadgentoo-2f9bac83cc23ff73f0271e3c83f3f683c4718806.tar.gz
gentoo-2f9bac83cc23ff73f0271e3c83f3f683c4718806.tar.bz2
gentoo-2f9bac83cc23ff73f0271e3c83f3f683c4718806.zip
dev-python/pyotherside: Bump to 1.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyotherside/Manifest1
-rw-r--r--dev-python/pyotherside/pyotherside-1.6.1.ebuild103
2 files changed, 104 insertions, 0 deletions
diff --git a/dev-python/pyotherside/Manifest b/dev-python/pyotherside/Manifest
index 6150ebef338c..7a770678cc78 100644
--- a/dev-python/pyotherside/Manifest
+++ b/dev-python/pyotherside/Manifest
@@ -1 +1,2 @@
DIST pyotherside-1.6.0.tar.gz 183645 BLAKE2B e2a12a9a96f3672a5e322c9f2e84d485b8086bdcacfc6586e0c23f6dd730d3e66cea66618540fd9a304480a9ab86386e2fe0136047c59f70bfa3b5cff9e8e76e SHA512 57835db9d65fae10e6b3ec8ab37793e316324e7a819a1045436adf9eabdee11ccf3090a4db0302283b236e77e5e0bd14cf92ed1430835ccc324e50085a872787
+DIST pyotherside-1.6.1.tar.gz 184539 BLAKE2B 32c017b6d3a64a3125f779a0201ee15288fbcc84bf070442dc542df525f5994cee6b334d86ff2bbbcada39f645ac2e900a459d729c4f8c838d529fb33bdf1226 SHA512 ea672405b97d09b3c4f1266b1714da5e127c47f8f1c99caa282bd823261c06a0b02e7094185724863f339a0bd35d45426bdf6e8cb7d37a8a23d1d18e81939d9d
diff --git a/dev-python/pyotherside/pyotherside-1.6.1.ebuild b/dev-python/pyotherside/pyotherside-1.6.1.ebuild
new file mode 100644
index 000000000000..366d71378ae4
--- /dev/null
+++ b/dev-python/pyotherside/pyotherside-1.6.1.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit multibuild qmake-utils python-single-r1
+
+DESCRIPTION="Asynchronous Python 3 Bindings for Qt"
+HOMEPAGE="
+ https://github.com/thp/pyotherside/
+ https://thp.io/2011/pyotherside/
+"
+SRC_URI="
+ https://github.com/thp/pyotherside/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+IUSE="qt5 qt6"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ || ( qt5 qt6 )
+"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtsvg:5
+ )
+ qt6? (
+ dev-qt/qtbase:6[opengl]
+ dev-qt/qtdeclarative:6[opengl]
+ dev-qt/qtquick3d:6[opengl]
+ dev-qt/qtsvg:6
+ )"
+RDEPEND="
+ ${DEPEND}
+"
+
+pkg_setup() {
+ MULTIBUILD_VARIANTS=( $(usev qt5) $(usev qt6) )
+ python_setup
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/qtquicktests//" pyotherside.pro || die
+ multibuild_copy_sources
+}
+
+src_configure() {
+ myconfigure() {
+ pushd "${BUILD_DIR}" > /dev/null || die
+
+ case ${MULTIBUILD_VARIANT} in
+ qt5)
+ eqmake5
+ ;;
+ qt6)
+ eqmake6
+ ;;
+ *)
+ # This should never happen if REQUIRED_USE is enforced
+ die "Neither Qt5 nor Qt6 support enabled, aborting"
+ ;;
+ esac
+
+ popd > /dev/null || die
+ }
+
+ multibuild_foreach_variant myconfigure
+}
+
+src_compile() {
+ mycompile() {
+ emake -C "${BUILD_DIR}"
+ }
+
+ multibuild_foreach_variant mycompile
+}
+
+src_test() {
+ mytest() {
+ QT_QPA_PLATFORM="offscreen" "${BUILD_DIR}"/tests/tests || die
+ }
+
+ multibuild_foreach_variant mytest
+}
+
+src_install() {
+ myinstall() {
+ emake -C "${BUILD_DIR}" install INSTALL_ROOT="${D}"
+ }
+
+ multibuild_foreach_variant myinstall
+}