summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2018-08-26 17:50:27 +0200
committerLouis Sautier <sbraz@gentoo.org>2018-08-27 09:11:21 +0200
commit2fae7cb90220af5884ca1604db864caf440978b3 (patch)
treea9d5ae765c4adfe62d9132f5f4fa013c3fbfdcf9
parentdev-ruby/autoprefixer-rails: add 9.1.3 (diff)
downloadgentoo-2fae7cb90220af5884ca1604db864caf440978b3.tar.gz
gentoo-2fae7cb90220af5884ca1604db864caf440978b3.tar.bz2
gentoo-2fae7cb90220af5884ca1604db864caf440978b3.zip
dev-python/dulwich: bump to 0.19.6, add Python 3.7
Package-Manager: Portage-2.3.48, Repoman-2.3.10 Closes: https://github.com/gentoo/gentoo/pull/9699
-rw-r--r--dev-python/dulwich/Manifest1
-rw-r--r--dev-python/dulwich/dulwich-0.19.6.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
index 98102c5c2b52..ca27387acaf2 100644
--- a/dev-python/dulwich/Manifest
+++ b/dev-python/dulwich/Manifest
@@ -1,3 +1,4 @@
DIST dulwich-0.18.5.tar.gz 330097 BLAKE2B c29f3016ab63082051c8c4fc42301c12ca752008a317afc41defceee2db47e50efb69b9a21b3d50c241b3b51c32222c1e9cf35eedaf2811f66cec2330ce7865a SHA512 4ba0f70ebddf4c7f4e71721812e228f820226d4ea42bda4d5f06a0720a029d4dddb800cfc05b2610525922c5fcef1020edd1485105706d9ef3fcf810e6381035
DIST dulwich-0.18.6.tar.gz 331325 BLAKE2B 781227bf91d8df8f941dd2eddb1682fb8c358d37f35671b08334ef197355e33dbbd09d18b43a179f9200cd6abca563a2fc833da68bd860859a52d951fe679ac0 SHA512 2d2120e23dd4bc2c9dcfe601f21ac757ee3fe2a343923c50b32c067f4d329ac89cdf0894bff450bf52c69e99759bb8692f0f14ed73d01be6bc3b0402d58d1148
DIST dulwich-0.19.4.tar.gz 349813 BLAKE2B a14dc2dccdb68df639a6a4bbf3aa8314fe831f7086573d7cd194f7426eb0021b2faa1663edf318b37031be90121e64a1186c381bfb2cd32a3824abac2a3aa52b SHA512 42aa7d35a491f2d98a8afae6e0afc68089f9d37dbd706961359f1d624a47c627dceb73bb614b608d29dd28faf87406f2e81b1ddcec607aeb0fabc9744b733232
+DIST dulwich-0.19.6.tar.gz 349939 BLAKE2B a88836c8a6fa3f732643f88cb94ec37c138146336709651f7fbc604fe80ff3dcf88b24ffca5e5d14c3c947b847a9678fa8b431ef6be0b78e6046bcd3f7ed29bc SHA512 7e13b465672c5eee4f6d14f28e9cba63ceddf1ad119822fabd17b01ad6b89c6dd8c0bbf562bdf50e0ada5ce17bcad531549054417d744e5cf64a610e8a1740bc
diff --git a/dev-python/dulwich/dulwich-0.19.6.ebuild b/dev-python/dulwich/dulwich-0.19.6.ebuild
new file mode 100644
index 000000000000..19df9baad280
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.19.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="https://github.com/jelmer/dulwich/ https://pypi.org/project/dulwich/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples test"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.21[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ ${RDEPEND}
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/geventhttpclient[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/python-fastimport[${PYTHON_USEDEP}]
+ )"
+
+DISTUTILS_IN_SOURCE_BUILD=1
+
+# One test sometimes fails
+# https://github.com/jelmer/dulwich/issues/541
+PATCHES=( "${FILESDIR}/${PN}-0.18.3-skip-failing-test.patch" )
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ # Do not use make check which rebuilds the extension and uses -Werror,
+ # causing unexpected failures.
+ "${EPYTHON}" -m unittest dulwich.tests.test_suite \
+ || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}