summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-26 05:16:54 +0100
committerSam James <sam@gentoo.org>2022-07-26 05:25:27 +0100
commit2fb298ff1bbdddac5f687a2deddaa554b338bcbc (patch)
tree2515e2d3b5b9d67ce714a28b9595feca081661fc
parentsys-fs/libeatmydata: drop 129-r1 (diff)
downloadgentoo-2fb298ff1bbdddac5f687a2deddaa554b338bcbc.tar.gz
gentoo-2fb298ff1bbdddac5f687a2deddaa554b338bcbc.tar.bz2
gentoo-2fb298ff1bbdddac5f687a2deddaa554b338bcbc.zip
sys-libs/musl-nscd: drop 1.0.3-r1
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-libs/musl-nscd/Manifest1
-rw-r--r--sys-libs/musl-nscd/files/musl-nscd-1.0.2-fno-common.patch36
-rw-r--r--sys-libs/musl-nscd/musl-nscd-1.0.3-r1.ebuild54
3 files changed, 0 insertions, 91 deletions
diff --git a/sys-libs/musl-nscd/Manifest b/sys-libs/musl-nscd/Manifest
index e3c2b5382c49..88436bb5a431 100644
--- a/sys-libs/musl-nscd/Manifest
+++ b/sys-libs/musl-nscd/Manifest
@@ -1,2 +1 @@
-DIST musl-nscd-1.0.3.tar.gz 45023 BLAKE2B de3985878745497f0f6904efba0ecf1c5d4ab96dd190fe0b776459db946749858821f51e75d457172da75cd68c5bba22143647b269473f35d41e0ab9bbac3e36 SHA512 b931a28d70bbcc19a5b592449e7400ee61d5af93511d44e2e63416010b3938f1d350a965b0ad876699bed406926d3180a0380868279e13d3456e2264c80a4b7d
DIST musl-nscd-1.1.1.tar.gz 51598 BLAKE2B 0c14cfed06f766e174154cdedf046eee8206822d21ce6ac0f1d2c253224a9c8be2fabe6a7d9c0e7c63d1811e3ccf06ca7b2c9dcb728cde445108039723e486c2 SHA512 f067b1491c6c46c3070aa2f61328b874eb6ad390c2efc928e2fee591ef5997b40400e29495546a861e803460efa46024c7a01c53ddae5b763ef63c2f274fceea
diff --git a/sys-libs/musl-nscd/files/musl-nscd-1.0.2-fno-common.patch b/sys-libs/musl-nscd/files/musl-nscd-1.0.2-fno-common.patch
deleted file mode 100644
index fce44ecdef7d..000000000000
--- a/sys-libs/musl-nscd/files/musl-nscd-1.0.2-fno-common.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/include/modules.h
-+++ b/include/modules.h
-@@ -28,7 +28,7 @@ struct mod_passwd {
- link_t link;
- };
-
--list_t passwd_mods;
--list_t group_mods;
-+extern list_t passwd_mods;
-+extern list_t group_mods;
-
- #endif
---- a/src/main.c
-+++ b/src/main.c
-@@ -18,6 +18,9 @@
- #include "parse.h"
- #include "util.h"
-
-+list_t passwd_mods;
-+list_t group_mods;
-+
- static void *get_dll(const char *service)
- {
- char *path;
---- a/src/socket_handle.c
-+++ b/src/socket_handle.c
-@@ -19,6 +19,9 @@
- #include "modules.h"
- #include "list.h"
-
-+extern list_t passwd_mods;
-+extern list_t group_mods;
-+
- static int return_result(int fd, int swap, uint32_t reqtype, void *key);
-
- struct pthread_args {
diff --git a/sys-libs/musl-nscd/musl-nscd-1.0.3-r1.ebuild b/sys-libs/musl-nscd/musl-nscd-1.0.3-r1.ebuild
deleted file mode 100644
index bec1e9b35ef1..000000000000
--- a/sys-libs/musl-nscd/musl-nscd-1.0.3-r1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit systemd tmpfiles
-
-DESCRIPTION="musl-nscd is an implementation of the NSCD protocol for the musl libc"
-HOMEPAGE="https://github.com/pikhq/musl-nscd"
-
-if [[ ${PV} == *9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/pikhq/musl-nscd"
- EGIT_BRANCH=master
-else
- SRC_URI="https://github.com/pikhq/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="minimal"
-
-DEPEND="
- !sys-libs/glibc"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PN}-1.0.2-fno-common.patch )
-
-src_prepare() {
- default
-
- sed -i '/LDFLAGS_AUTO=-s/d' configure || die "Cannot patch configure file"
-}
-
-src_install() {
- if use minimal; then
- emake DESTDIR="${D}" install-headers
- else
- emake DESTDIR="${D}" install
-
- newinitd "${FILESDIR}"/nscd.initd nscd
- systemd_dounit "${FILESDIR}"/nscd.service
- newtmpfiles "${FILESDIR}"/nscd.tmpfilesd nscd.conf
-
- dodoc README
- fi
-}
-
-pkg_postinst() {
- if ! use minimal; then
- tmpfiles_process nscd.conf
- fi
-}