summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2020-11-19 00:00:00 +0000
committerMike Gilbert <floppym@gentoo.org>2020-11-22 14:31:50 -0500
commit2fd03636fc46e1a070b0f2521ba79490524d73c8 (patch)
tree86fa9c5ebba1d4571de61039cc6fcb15a1e6d1b9
parentx11-wm/mutter: remove old (diff)
downloadgentoo-2fd03636fc46e1a070b0f2521ba79490524d73c8.tar.gz
gentoo-2fd03636fc46e1a070b0f2521ba79490524d73c8.tar.bz2
gentoo-2fd03636fc46e1a070b0f2521ba79490524d73c8.zip
dev-libs/utfcpp: Use cmake.eclass.
Signed-off-by: Arfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org> Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--dev-libs/utfcpp/utfcpp-3.1.ebuild6
-rw-r--r--dev-libs/utfcpp/utfcpp-9999.ebuild8
2 files changed, 7 insertions, 7 deletions
diff --git a/dev-libs/utfcpp/utfcpp-3.1.ebuild b/dev-libs/utfcpp/utfcpp-3.1.ebuild
index 5afa6b050632..65c032f5f0ab 100644
--- a/dev-libs/utfcpp/utfcpp-3.1.ebuild
+++ b/dev-libs/utfcpp/utfcpp-3.1.ebuild
@@ -3,7 +3,7 @@
EAPI="7"
-inherit cmake-utils
+inherit cmake
if [[ "${PV}" == "9999" ]]; then
inherit git-r3
@@ -34,7 +34,7 @@ src_prepare() {
sed -e "/add_subdirectory(extern\/gtest)/d" -i CMakeLists.txt || die
sed -e "s/gtest_main/gtest &/" -i tests/CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -43,5 +43,5 @@ src_configure() {
-DUTF8_TESTS=$(usex test ON OFF)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
diff --git a/dev-libs/utfcpp/utfcpp-9999.ebuild b/dev-libs/utfcpp/utfcpp-9999.ebuild
index 2b6fa17b5966..ca5002a61255 100644
--- a/dev-libs/utfcpp/utfcpp-9999.ebuild
+++ b/dev-libs/utfcpp/utfcpp-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2015-2019 Gentoo Authors
+# Copyright 2015-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-inherit cmake-utils
+inherit cmake
if [[ "${PV}" == "9999" ]]; then
inherit git-r3
@@ -34,7 +34,7 @@ src_prepare() {
sed -e "/add_subdirectory(extern\/gtest)/d" -i CMakeLists.txt || die
sed -e "s/gtest_main/gtest &/" -i tests/CMakeLists.txt || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -43,5 +43,5 @@ src_configure() {
-DUTF8_TESTS=$(usex test ON OFF)
)
- cmake-utils_src_configure
+ cmake_src_configure
}