summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-09-15 12:58:32 -0700
committerMatt Turner <mattst88@gentoo.org>2021-09-15 13:27:08 -0700
commit2fdfd2efca62435387acfe82bb4ac880cfdfbb93 (patch)
tree6690d5fad6110071a9e879c12702576bb9365ed5
parentdev-python/zeroconf: Bump to 0.36.3 (diff)
downloadgentoo-2fdfd2ef.tar.gz
gentoo-2fdfd2ef.tar.bz2
gentoo-2fdfd2ef.zip
x11-base/xorg-proto: Version bump to 2021.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-base/xorg-proto/Manifest1
-rw-r--r--x11-base/xorg-proto/xorg-proto-2021.5.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/x11-base/xorg-proto/Manifest b/x11-base/xorg-proto/Manifest
index fb8f14bd86a7..e577d59f4d91 100644
--- a/x11-base/xorg-proto/Manifest
+++ b/x11-base/xorg-proto/Manifest
@@ -1,2 +1,3 @@
DIST xorgproto-2021.4.99.2.tar.gz 1143087 BLAKE2B eabdbc903a058a9be919192ac71fc95cedc2ff58e131a0eae6454be1e03714fb592d020ce8d9a4915a620de2a4d1c7cf2c5939c53ba96199f2a2ea579c450606 SHA512 34c4cb2aa97568be5ac5480c86122e9733afab3d17d48d170636aa10b39a99d6d637864d872ab78040a468ee3896a1aa42f5124bc8a4901dbb4b543eada7a607
DIST xorgproto-2021.4.tar.gz 1141941 BLAKE2B 016a3c2f30ed064855de2a13d86a4b7bc9420ff10e8ac3ba97e08512fef6f0495a69dcaea7f12c7d8694a52284b500a38aee73de7bf2ff0a295715354d04eab0 SHA512 5f4c94d3ee20635f2358d7644be54d5e291bafba15a7713583acbb3564c2799da4ba33ffba625273fe015e4ab733cbaec146467804fd2174eb5fd1ff3bf21019
+DIST xorgproto-2021.5.tar.gz 1132811 BLAKE2B 3fe288cf8a848436dacc0ebf437b6a1d2c81878abaf8c542ff45e70389643cb2bc25bdab5ab6ff9d44a4f9bbdbd24757d21617c2c6a0754870afcd9f60ccbb05 SHA512 9c9ec62f0af68fd0dff24010986326a2b201be2b56b8b94abfe7258bf66b3c4c37088596c43a234aae63b1d781f7797caf408e434c98e8805803bc890b8aacb0
diff --git a/x11-base/xorg-proto/xorg-proto-2021.5.ebuild b/x11-base/xorg-proto/xorg-proto-2021.5.ebuild
new file mode 100644
index 000000000000..3544d1e5d5eb
--- /dev/null
+++ b/x11-base/xorg-proto/xorg-proto-2021.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+MY_PN="${PN/xorg-/xorg}"
+MY_P="${MY_PN}-${PV}"
+
+EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/proto/${MY_PN}.git"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+fi
+
+inherit ${GIT_ECLASS} meson python-any-r1
+
+DESCRIPTION="X.Org combined protocol headers"
+HOMEPAGE="https://gitlab.freedesktop.org/xorg/proto/xorgproto"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x64-solaris"
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/proto/${MY_P}.tar.gz"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? (
+ $(python_gen_any_dep '
+ dev-python/python-libevdev[${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND=""
+
+python_check_deps() {
+ has_version -b "dev-python/python-libevdev[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_install() {
+ meson_src_install
+
+ mv "${ED}"/usr/share/doc/{xorgproto,${P}} || die
+}