summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-01-02 18:48:57 +0100
committerDavid Seifert <soap@gentoo.org>2022-01-02 18:48:57 +0100
commit2fe8ec9a396003da52aff7d2564f1faaa2830b08 (patch)
treedf7f910d8fd87b6fecca818ed2da4e3e572a588f
parentsys-devel/gdb: remove freebsd-libc (diff)
downloadgentoo-2fe8ec9a.tar.gz
gentoo-2fe8ec9a.tar.bz2
gentoo-2fe8ec9a.zip
sys-fs/e2fsprogs: remove freebsd-libc
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.46.4.ebuild20
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.46.5.ebuild24
2 files changed, 2 insertions, 42 deletions
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.46.4.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.46.4.ebuild
index 7621c508cced..225c1d41eb95 100644
--- a/sys-fs/e2fsprogs/e2fsprogs-1.46.4.ebuild
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.46.4.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://www.kernel.org/pub/linux/kernel/people/tytso/e2fsprogs/v${PV}/$
LICENSE="GPL-2 BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="cron fuse lto nls static-libs +threads elibc_FreeBSD"
+IUSE="cron fuse lto nls static-libs +threads"
RDEPEND="~sys-libs/${PN}-libs-${PV}
>=sys-apps/util-linux-2.16
@@ -93,12 +93,6 @@ src_configure() {
src_compile() {
emake V=1 COMPILE_ET=compile_et MK_CMDS=mk_cmds
-
- # Build the FreeBSD helper
- if use elibc_FreeBSD ; then
- cp "${FILESDIR}"/fsck_ext2fs.c .
- emake V=1 fsck_ext2fs
- fi
}
src_install() {
@@ -123,16 +117,4 @@ src_install() {
if ! use static-libs ; then
find "${ED}" -name '*.a' -delete || die
fi
-
- if use elibc_FreeBSD ; then
- # Install helpers for us
- into /
- dosbin "${S}"/fsck_ext2fs
- doman "${FILESDIR}"/fsck_ext2fs.8
-
- # filefrag is linux only
- rm \
- "${ED}"/usr/sbin/filefrag \
- "${ED}"/usr/share/man/man8/filefrag.8 || die
- fi
}
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.46.5.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.46.5.ebuild
index a460cd4a48e1..3e84085d14a9 100644
--- a/sys-fs/e2fsprogs/e2fsprogs-1.46.5.ebuild
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.46.5.ebuild
@@ -12,7 +12,7 @@ SRC_URI="https://www.kernel.org/pub/linux/kernel/people/tytso/e2fsprogs/v${PV}/$
LICENSE="GPL-2 BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="cron fuse lto nls static-libs +threads +tools elibc_FreeBSD"
+IUSE="cron fuse lto nls static-libs +threads +tools"
RDEPEND="
!sys-libs/${PN}-libs
@@ -112,12 +112,6 @@ multilib_src_compile() {
fi
emake V=1
-
- # Build the FreeBSD helper
- if use elibc_FreeBSD ; then
- cp "${FILESDIR}"/fsck_ext2fs.c . || die
- emake V=1 fsck_ext2fs
- fi
}
multilib_src_test() {
@@ -148,12 +142,6 @@ multilib_src_install() {
# Move shared libraries to /lib/, install static libraries to
# /usr/lib/, and install linker scripts to /usr/lib/.
gen_usr_ldscript -a e2p ext2fs
-
- if use elibc_FreeBSD ; then
- # Install helpers for us
- into /
- dosbin "${S}"/fsck_ext2fs
- fi
fi
gen_usr_ldscript -a com_err ss $(usex kernel_linux '' 'uuid blkid')
@@ -170,15 +158,5 @@ multilib_src_install_all() {
if use tools ; then
insinto /etc
doins "${FILESDIR}"/e2fsck.conf
-
- if use elibc_FreeBSD ; then
- into /
- doman "${FILESDIR}"/fsck_ext2fs.8
-
- # filefrag is linux only
- rm \
- "${ED}"/usr/sbin/filefrag \
- "${ED}"/usr/share/man/man8/filefrag.8 || die
- fi
fi
}