summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-09 09:19:22 +0200
committerHans de Graaff <graaff@gentoo.org>2021-10-09 09:27:49 +0200
commit300a6e682e72c22ab566d389a48abc3b50669122 (patch)
treef9a24fe090409531f075ad5b60b5812a599f719a
parentdev-ruby/async_sinatra: EAPI 8; add ruby27 (diff)
downloadgentoo-300a6e68.tar.gz
gentoo-300a6e68.tar.bz2
gentoo-300a6e68.zip
dev-ruby/amq-client: EAPI 8; add ruby27
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/amq-client/amq-client-1.0.4-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/amq-client/amq-client-1.0.4-r1.ebuild b/dev-ruby/amq-client/amq-client-1.0.4-r1.ebuild
new file mode 100644
index 000000000000..34a9498d3994
--- /dev/null
+++ b/dev-ruby/amq-client/amq-client-1.0.4-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.textile"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A fully-featured, low-level AMQP 0.9.1 client"
+HOMEPAGE="https://github.com/ruby-amqp/amq-client"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/amq-protocol-1.2.0 dev-ruby/eventmachine"
+
+ruby_add_bdepend "test? ( dev-ruby/evented-spec )"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' -e '/effin_utf8/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '7i require "evented-spec"' spec/spec_helper.rb || die
+
+ # Drop integration tests since these require a running AMQP server.
+ rm -rf spec/integration spec/regression/bad_frame_slicing_in_adapters_spec.rb spec/unit/client_spec.rb || die
+}