summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-05-21 12:32:57 +0100
committerMarek Szuba <marecki@gentoo.org>2024-05-21 12:38:47 +0100
commit3024a3c1fdc1a78d1a2ffae796d455b5e0296a5f (patch)
tree06a4e6d258909336527cf6b42ee73ff3381bd3ec
parentapp-backup/borgmatic: add 1.8.11 (diff)
downloadgentoo-3024a3c1fdc1a78d1a2ffae796d455b5e0296a5f.tar.gz
gentoo-3024a3c1fdc1a78d1a2ffae796d455b5e0296a5f.tar.bz2
gentoo-3024a3c1fdc1a78d1a2ffae796d455b5e0296a5f.zip
sys-block/whdd: add 3.1
Upstream now provides CMake build scripts as well but they do not appear to be ready yet, as in addition to not respecting user CFLAGS (easily fixed) whdd built with CMake immediately segfaults. Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--sys-block/whdd/Manifest1
-rw-r--r--sys-block/whdd/whdd-3.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-block/whdd/Manifest b/sys-block/whdd/Manifest
index c2bc70e91df6..a749ef279c3a 100644
--- a/sys-block/whdd/Manifest
+++ b/sys-block/whdd/Manifest
@@ -1 +1,2 @@
DIST whdd-3.0.1-rel.tar.gz 45657 BLAKE2B 9730e61580359c95fc3e3d23540f3b10e75b476e634cce3be744b8849193f43f968f227bdbd25a0c643106c1343b27070c8b51f33278e902ab54991a05eee021 SHA512 6d5d8dad7537118a5915a29a549e18595da1b6ba031f0ca661805ad0033fd48f32804eb307f67e7b31d6002e708ae578a32aff366f3e610ab36b25f0a4e50803
+DIST whdd-3.1-rel.tar.gz 45806 BLAKE2B dce0230955fda721539891f0e993f25d3777e7d11331bbbd7b7e853dafd2edba043fc598c672634cc8bb65bad5c0ae9f3e26713f98c0d551dc72d08de20e1eb4 SHA512 8960b482d7c3a75b0b9e540092a0c074dbb66561f455fdf454e8cd89cc5dc4dc028e60b44ce74ecbf568af5e7e34a5b3b5deaee9480112f4161d98b773442bed
diff --git a/sys-block/whdd/whdd-3.1.ebuild b/sys-block/whdd/whdd-3.1.ebuild
new file mode 100644
index 000000000000..5009455fad36
--- /dev/null
+++ b/sys-block/whdd/whdd-3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Diagnostic and recovery tool for block devices"
+HOMEPAGE="https://whdd.github.io"
+
+inherit toolchain-funcs
+
+if [[ ${PV} == 9999 ]]
+then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}-rel.tar.gz"
+ KEYWORDS="~amd64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+DEPEND="dev-util/dialog:=
+ sys-libs/ncurses:=[unicode(+)]"
+RDEPEND="${DEPEND}
+ sys-apps/smartmontools"
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ einstalldocs
+}