summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-02 12:29:38 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-02 12:40:37 +0200
commit30367782575a3b0647d898b474a070da59ec2eb8 (patch)
treeae25d75810cef7a2e64f54a7161fea4c300eb5cb
parentdev-util/meson: sparc stable (diff)
downloadgentoo-30367782.tar.gz
gentoo-30367782.tar.bz2
gentoo-30367782.zip
app-backup/backupninja: Fix logs location (#578614)
Package-Manager: Portage-2.3.27, Repoman-2.3.9
-rw-r--r--app-backup/backupninja/backupninja-1.0.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-backup/backupninja/backupninja-1.0.1-r1.ebuild b/app-backup/backupninja/backupninja-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..793e1f9e1589
--- /dev/null
+++ b/app-backup/backupninja/backupninja-1.0.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+# This thing change with every release, how idiotic...
+NODE_NUMBER=275
+
+DESCRIPTION="lightweight, extensible meta-backup system"
+HOMEPAGE="http://riseuplabs.org/backupninja/"
+SRC_URI="https://labs.riseup.net/code/attachments/download/${NODE_NUMBER}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-util/dialog"
+DEPEND=""
+
+src_prepare() {
+ default
+ mv configure.in configure.ac
+ eautoreconf
+}
+
+src_configure() {
+ econf --localstatedir=/var #578614
+}