summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 18:01:20 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:34:02 +0100
commit304623dfcd7271ea0da71f9a496a8564fb31c01a (patch)
treed56e1755b30e7d2f0a9bee5f6b7bf6924b26ef75
parentnet-analyzer/gr-fosphor: Switch to PYTHON_SINGLE_USEDEP (diff)
downloadgentoo-304623dfcd7.tar.gz
gentoo-304623dfcd7.tar.bz2
gentoo-304623dfcd7.zip
net-analyzer/nmap: Switch to PYTHON_MULTI_USEDEP API
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--net-analyzer/nmap/nmap-7.70-r1.ebuild (renamed from net-analyzer/nmap/nmap-7.70.ebuild)6
-rw-r--r--net-analyzer/nmap/nmap-7.80-r1.ebuild (renamed from net-analyzer/nmap/nmap-7.80.ebuild)6
-rw-r--r--net-analyzer/nmap/nmap-9999.ebuild4
3 files changed, 11 insertions, 5 deletions
diff --git a/net-analyzer/nmap/nmap-7.70.ebuild b/net-analyzer/nmap/nmap-7.70-r1.ebuild
index 4dd557296213..f6b7e054ca37 100644
--- a/net-analyzer/nmap/nmap-7.70.ebuild
+++ b/net-analyzer/nmap/nmap-7.70-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -47,7 +47,9 @@ RDEPEND="
)
system-lua? ( >=dev-lang/lua-5.2:*[deprecated] )
zenmap? (
- dev-python/pygtk:2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pygtk:2[${PYTHON_MULTI_USEDEP}]
+ ')
${PYTHON_DEPS}
)
"
diff --git a/net-analyzer/nmap/nmap-7.80.ebuild b/net-analyzer/nmap/nmap-7.80-r1.ebuild
index 3d1303bd82a8..a742c24a2323 100644
--- a/net-analyzer/nmap/nmap-7.80.ebuild
+++ b/net-analyzer/nmap/nmap-7.80-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -50,7 +50,9 @@ RDEPEND="
)
system-lua? ( >=dev-lang/lua-5.2:*[deprecated] )
zenmap? (
- dev-python/pygtk:2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pygtk:2[${PYTHON_MULTI_USEDEP}]
+ ')
${PYTHON_DEPS}
)
"
diff --git a/net-analyzer/nmap/nmap-9999.ebuild b/net-analyzer/nmap/nmap-9999.ebuild
index e5440fa3e63e..7f9ceb695c1b 100644
--- a/net-analyzer/nmap/nmap-9999.ebuild
+++ b/net-analyzer/nmap/nmap-9999.ebuild
@@ -48,7 +48,9 @@ RDEPEND="
)
system-lua? ( >=dev-lang/lua-5.2:*[deprecated] )
zenmap? (
- dev-python/pygtk:2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/pygtk:2[${PYTHON_MULTI_USEDEP}]
+ ')
${PYTHON_DEPS}
)
"