summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-05-13 13:40:44 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-05-13 13:43:21 +0200
commit3046a0fbf2b731804b63f4f02db3b924954f5f2a (patch)
tree861f4fb7b47d239595e6370d678f1187d8893fa4
parentx11-misc/xscreensaver: Fix indentation (diff)
downloadgentoo-3046a0fbf2b731804b63f4f02db3b924954f5f2a.tar.gz
gentoo-3046a0fbf2b731804b63f4f02db3b924954f5f2a.tar.bz2
gentoo-3046a0fbf2b731804b63f4f02db3b924954f5f2a.zip
app-office/homebank: add 5.8
Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
-rw-r--r--app-office/homebank/Manifest1
-rw-r--r--app-office/homebank/homebank-5.8.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/app-office/homebank/Manifest b/app-office/homebank/Manifest
index 9aa0e7db9838..a726feb3f8f0 100644
--- a/app-office/homebank/Manifest
+++ b/app-office/homebank/Manifest
@@ -1 +1,2 @@
DIST homebank-5.7.4.tar.gz 3670067 BLAKE2B 3be94dc9e1ec11fc67fb7dab1655c9e2ab8529887cba200331e938b02a97abf810d94823443de0f5faf1b6beda85f9208e26909a876c3828ae2a1aab38890db0 SHA512 d65127b49a7566f5ad88feb8c614883c43e322ea50d915e49691b169771fac222573da4988ab1c54d9f39b9dfdf2d724cba07269e093c67a04900828d0b87093
+DIST homebank-5.8.tar.gz 3714120 BLAKE2B 72c8f635a6328df767cb2d94195dccf067cec98266c820e3fcfd764886aaffd5341130b6102e7e56b6623dfc2f78658a5dcad7f23839e0091c0d10a8674b2a4f SHA512 c004cdb88e905d24554ecc52632ca92d5a13ffd61addfdea3374a09ea6f53b848a9f92f4b3eebae06550d72898fd318482c8ab21cb0bb2366c63ff89ac0f349d
diff --git a/app-office/homebank/homebank-5.8.ebuild b/app-office/homebank/homebank-5.8.ebuild
new file mode 100644
index 000000000000..477ea294339b
--- /dev/null
+++ b/app-office/homebank/homebank-5.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg
+
+DESCRIPTION="Free, easy, personal accounting for everyone"
+HOMEPAGE="
+ https://www.gethomebank.org/
+ https://launchpad.net/homebank
+"
+SRC_URI="https://www.gethomebank.org/public/sources/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+ofx"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.39:2
+ net-libs/libsoup:3.0
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/pango
+ ofx? ( >=dev-libs/libofx-0.8.3:= )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ >=dev-lang/perl-5.8.1
+ dev-perl/XML-Parser
+ >=dev-util/intltool-0.40.5
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_configure() {
+ econf $(use_with ofx)
+}