summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-01 05:38:22 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-01 06:07:25 +0200
commit3048cee3dfc124bca78fbc4c218711030416cc3b (patch)
tree673586da7be902ce2e4519c743de9e6e3ba0643f
parentdev-python/nbformat: Bump to 5.9.0 (diff)
downloadgentoo-3048cee3dfc124bca78fbc4c218711030416cc3b.tar.gz
gentoo-3048cee3dfc124bca78fbc4c218711030416cc3b.tar.bz2
gentoo-3048cee3dfc124bca78fbc4c218711030416cc3b.zip
net-misc/electrum: Bump to 4.4.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--net-misc/electrum/Manifest1
-rw-r--r--net-misc/electrum/electrum-4.4.4.ebuild112
2 files changed, 113 insertions, 0 deletions
diff --git a/net-misc/electrum/Manifest b/net-misc/electrum/Manifest
index 9d43c6ed3568..9abb413f6976 100644
--- a/net-misc/electrum/Manifest
+++ b/net-misc/electrum/Manifest
@@ -3,3 +3,4 @@ DIST electrum-4.4.0.gh.tar.gz 5627801 BLAKE2B 27ed9fff7586f9efe18a76f3cfa6d0cc4d
DIST electrum-4.4.1.gh.tar.gz 5631256 BLAKE2B cefa27c7b770429004a221143f4291285f2ad6f3ca6f1f58c5c98ce6b6efbc316ea6b857a6abf8ed899cf5feac1f3505fd83189849aab72f144af9e7ce4d546d SHA512 075253fc89063d8fa6adcdc9d3e4c7cbd5caa27efe9f5dca8ddf5ef3863ca25690f2a4280a4999d6d3da7d32ece10dd9faf2ba560d2b13a0c9887237daa6382e
DIST electrum-4.4.2.gh.tar.gz 5635869 BLAKE2B 7ba1941a59e5db7578d2b7fe26997c9bda92467362422fc3b3741eefc5c52b872cbb0c9c5caf7454ae4b6136a37b498ba2afd1b0f19ace0f566de68a9e40b3bb SHA512 50509a7890a9697dfb59ec6d8cb3f2d5243b37acbff2c322cb7a6f4b350dd18fc5a963a30af6cd4e918ea02306df4da7252158ddf268fc87762ff598e2eb33e8
DIST electrum-4.4.3.gh.tar.gz 5629690 BLAKE2B 56f1bf2500500eb9fcd3b0397adee2f46865ab628004c62b2ffc36b7a019b1bd94b7c84576b35afda70116fb290476432fb1363eeb511d8cd4e6342c3a920975 SHA512 077742c404cce57fbf330b28a36c277dc22c10027c8f412ea192a7f7b917b37b22bbb85dc6cdc654daaacc28f98659dac406879a183448b20b0377a86697f486
+DIST electrum-4.4.4.gh.tar.gz 5630721 BLAKE2B 89505aee1be9fd66a57544d7fb9dc01b09c121529aebc63021f460a4a210bdce7d911854d3547e4710b6d44f329abe8fdc3c59d2a2776b1f470cf26c91de6e6a SHA512 cb59ee0f0a427bf6aa3d6d707a4a188aa0e4c9e957af748908c1f617ac49416a0015a6c5f4763b6ef5e4f67a7fcb827f2bd31825e8b42ebc3cca7da0c72a1bc0
diff --git a/net-misc/electrum/electrum-4.4.4.ebuild b/net-misc/electrum/electrum-4.4.4.ebuild
new file mode 100644
index 000000000000..693674eca7e3
--- /dev/null
+++ b/net-misc/electrum/electrum-4.4.4.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="ncurses?"
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="User friendly Bitcoin client"
+HOMEPAGE="
+ https://electrum.org/
+ https://github.com/spesmilo/electrum/
+"
+SRC_URI="
+ https://github.com/spesmilo/electrum/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cli ncurses qrcode +qt5"
+REQUIRED_USE="|| ( cli ncurses qt5 )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ <dev-libs/libsecp256k1-0.4
+ >=dev-python/aiohttp-socks-0.3[${PYTHON_USEDEP}]
+ =dev-python/aiorpcX-0.22*[${PYTHON_USEDEP}]
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ dev-python/bitstring[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/dnspython-2[${PYTHON_USEDEP}]
+ dev-python/pbkdf2[${PYTHON_USEDEP}]
+ dev-python/PySocks[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/protobuf-python-3.20[${PYTHON_USEDEP}]
+ qrcode? ( media-gfx/zbar[v4l] )
+ qt5? (
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+ )
+ ncurses? ( $(python_gen_impl_dep 'ncurses') )
+"
+BDEPEND="
+ test? (
+ dev-python/pyaes[${PYTHON_USEDEP}]
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # use backwards-compatible cryptodome API
+ sed -i -e 's:Cryptodome:Crypto:' electrum/crypto.py || die
+
+ # make qdarkstyle dep optional
+ sed -i -e '/qdarkstyle/d' contrib/requirements/requirements.txt || die
+
+ # remove upper bounds from deps
+ sed -i -e 's:,<[0-9.]*::' contrib/requirements/requirements.txt || die
+
+ local bestgui
+ if use qt5; then
+ bestgui=qt
+ elif use ncurses; then
+ bestgui=text
+ else
+ bestgui=stdio
+ fi
+ sed -i 's/^\([[:space:]]*\)\(config_options\['\''cwd'\''\] = .*\)$/\1\2\n\1config_options.setdefault("gui", "'"${bestgui}"'")\n/' ${PN}/${PN} || die
+
+ eapply_user
+
+ xdg_environment_reset
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ dodoc RELEASE-NOTES
+ distutils-r1_src_install
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+
+ local v
+ for v in ${REPLACING_VERSIONS}; do
+ ver_test "${v}" -ge 4.3.4 && return
+ done
+
+ ewarn "If you are new to BitCoin, please be aware that:"
+ ewarn "1. Cryptocurrencies are volatile. BTC has been subject to rapid"
+ ewarn " changes of value in the past."
+ ewarn "2. Cryptocurrency ownership is determined solely by the access to"
+ ewarn " the private key. If the key is lost or stolen, BTC are unrevocably"
+ ewarn " lost."
+ ewarn "3. Proof-of-work based cryptocurrencies have negative environmental"
+ ewarn " impact. BTC mining is consuming huge amounts of electricity."
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}