summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-04-15 22:10:41 -0400
committerMatt Turner <mattst88@gentoo.org>2021-04-15 22:11:49 -0400
commit30698ab4a915450dfcc8b93053b17e313602d79b (patch)
tree09c469ced1b106f7e6129f393b1e236d351a8f29
parentgnome-base/gnome-session: Version bump to 40.0 (diff)
downloadgentoo-30698ab4.tar.gz
gentoo-30698ab4.tar.bz2
gentoo-30698ab4.zip
gnome-extra/gnome-weather: Version bump to 40.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-extra/gnome-weather/Manifest1
-rw-r--r--gnome-extra/gnome-weather/gnome-weather-40.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/gnome-extra/gnome-weather/Manifest b/gnome-extra/gnome-weather/Manifest
index 2003db5dfdab..48ad6fce7c63 100644
--- a/gnome-extra/gnome-weather/Manifest
+++ b/gnome-extra/gnome-weather/Manifest
@@ -1 +1,2 @@
DIST gnome-weather-3.36.1.tar.xz 5959192 BLAKE2B f0745506ffd2b72a1a5fe0783fe04c563691840fdf2150e7850cd331ba2027b1d1fcbbb4565830d05c7e39e62a2c94e4c87443ce5786cc70f3ebabcc66e97eec SHA512 c3d4b0e7258c0bfbc1ab2b5695d601fe79326e1bed856734edc309c612f1cc0adc9cfd6b4afb4ad3069b864c807ca0b21a60f89feba68f1dacac58d0fd2221be
+DIST gnome-weather-40.0.tar.xz 938732 BLAKE2B bc46da61e9620278f5abc7964b869520da85837739923618b2ade114c8561fc6125e7dca2f2aef5715fec7dfa0561c693f75278d050900cb948f8d1ea42f58ba SHA512 c4560c1a1535a0c2889c8cd934926217a7caceb1b646fa4bb961c7cbde38b9b545a567f24fb81e47c61a2ac3e456a5432e8979591eb5a169fe5849bbd99d6333
diff --git a/gnome-extra/gnome-weather/gnome-weather-40.0.ebuild b/gnome-extra/gnome-weather/gnome-weather-40.0.ebuild
new file mode 100644
index 000000000000..f468aa083404
--- /dev/null
+++ b/gnome-extra/gnome-weather/gnome-weather-40.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A weather application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Weather"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.56:=
+ >=x11-libs/gtk+-3.20:3
+ >=dev-libs/gjs-1.50
+ >=app-misc/geoclue-2.3.1:2.0
+ >=dev-libs/libgweather-3.28:=
+ >=gui-libs/libhandy-1.1.90:1=
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# Tests have a lot of issues, starting with reliance on a system installation,
+# accessing the network and other intermittent failures with network-sandbox disabled
+# https://gitlab.gnome.org/GNOME/gnome-weather/issues/67 (and rest not filed)
+# test dep: $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]')
+# With 3.34, this is now behind a dogtail option we can pass (and have data validation)
+
+src_configure() {
+ meson_src_configure -Dprofile=default -Ddogtail=false
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}