summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-07-25 11:49:21 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-25 11:49:21 +0200
commit3073a953a419510c39b533a26c8298fd8c32f0ca (patch)
tree14f07226f0389e90357ddac6b15fa242313a19d4
parentkde-misc/kdiff3: drop 1.9.5 (diff)
downloadgentoo-3073a953a419510c39b533a26c8298fd8c32f0ca.tar.gz
gentoo-3073a953a419510c39b533a26c8298fd8c32f0ca.tar.bz2
gentoo-3073a953a419510c39b533a26c8298fd8c32f0ca.zip
dev-util/cram: update EAPI 7 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-util/cram/cram-0.7-r2.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/dev-util/cram/cram-0.7-r2.ebuild b/dev-util/cram/cram-0.7-r2.ebuild
index 56867074f7fe..3c610b79f921 100644
--- a/dev-util/cram/cram-0.7-r2.ebuild
+++ b/dev-util/cram/cram-0.7-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
@@ -17,6 +17,5 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~x86"
python_test() {
- distutils_install_for_testing
- "${EPYTHON}" "${TEST_DIR}"/scripts/cram tests || die "Tests fail with ${EPYTHON}"
+ "${EPYTHON}" scripts/cram tests || die "Tests fail with ${EPYTHON}"
}