summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2022-03-05 00:47:09 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2022-03-05 23:39:25 +0100
commit307546f675180e3ad64c3a5cfc3bd34f37088d0e (patch)
tree4208197358233f261adcd065f625a797304dad1a
parentgames-misc/xcowsay: drop 1.5.1 (diff)
downloadgentoo-307546f675180e3ad64c3a5cfc3bd34f37088d0e.tar.gz
gentoo-307546f675180e3ad64c3a5cfc3bd34f37088d0e.tar.bz2
gentoo-307546f675180e3ad64c3a5cfc3bd34f37088d0e.zip
media-libs/lensfun: Version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
-rw-r--r--media-libs/lensfun/Manifest1
-rw-r--r--media-libs/lensfun/lensfun-0.3.3.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/media-libs/lensfun/Manifest b/media-libs/lensfun/Manifest
index 3c89adacf4f9..34fb903338a0 100644
--- a/media-libs/lensfun/Manifest
+++ b/media-libs/lensfun/Manifest
@@ -1 +1,2 @@
DIST lensfun-0.3.2.tar.gz 784825 BLAKE2B c77cd6b2f1bda0313a980fbd3bbc7ca9ad5ed0b9777cce924f66da5de3974ccfc8939d054c7a7532508b6b0913e2d436a825a83916800b625ff2c552c96a0ae3 SHA512 9c6f546fa70e6dc692e66ef378447345be6d3383812934780d326d772d775c1918cbf3447cd91c067655044cf659025763bf47ba2d938a82a3c2de4d60127446
+DIST lensfun-0.3.3.tar.gz 992432 BLAKE2B 174f9a34195ca8d7f09de43a2f0d1015bc766579607c44541f631142386a3b5c27c823f9f54f08d462946a0809610b6a87e61cd093b69339fa7d57d28cc833ae SHA512 2d913e3d121ac069f4cb7acb3f09c9cf11c5d0069e743500631bd4b6007a1b19ebccf871a4ac8cfc2797a03066f8a678ea9d70feba0f7d6a05c28cef61f7d9cf
diff --git a/media-libs/lensfun/lensfun-0.3.3.ebuild b/media-libs/lensfun/lensfun-0.3.3.ebuild
new file mode 100644
index 000000000000..8911ea725f13
--- /dev/null
+++ b/media-libs/lensfun/lensfun-0.3.3.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-single-r1 cmake
+
+DESCRIPTION="Library for rectifying and simulating photographic lens distortions"
+HOMEPAGE="https://lensfun.github.io"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3 CC-BY-SA-3.0" # See README for reasoning.
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc cpu_flags_x86_sse cpu_flags_x86_sse2 test"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ doc? (
+ app-doc/doxygen
+ dev-python/docutils
+ )
+"
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.40
+ media-libs/libpng:0=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( README.md docs/mounts.txt ChangeLog )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.3.2-warnings.patch"
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DOCDIR="${EPREFIX}"/usr/share/doc/${PF}/html
+ -DSETUP_PY_INSTALL_PREFIX=/usr
+ -DBUILD_LENSTOOL=ON
+ -DBUILD_STATIC=OFF
+ -DBUILD_DOC=$(usex doc)
+ -DBUILD_FOR_SSE=$(usex cpu_flags_x86_sse)
+ -DBUILD_FOR_SSE2=$(usex cpu_flags_x86_sse2)
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ mkdir -p "${T}/db/lensfun" || die
+ cp data/db/* "${T}/db/lensfun/" || die
+
+ XDG_DATA_HOME="${T}/db" cmake_src_test
+}
+
+src_install() {
+ cmake_src_install
+ python_optimize
+}