summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-02-01 11:25:35 -0500
committerMatt Turner <mattst88@gentoo.org>2023-02-01 11:26:16 -0500
commit3079944a5506fd9f9daae8513ad883adca21e836 (patch)
treef1af4ef4a5fa604423c44da5c4b3cdde0e66017d
parentmedia-libs/libpulse: Stabilize 16.1-r2 arm64, #892147 (diff)
downloadgentoo-3079944a5506fd9f9daae8513ad883adca21e836.tar.gz
gentoo-3079944a5506fd9f9daae8513ad883adca21e836.tar.bz2
gentoo-3079944a5506fd9f9daae8513ad883adca21e836.zip
sci-geosciences/gnome-maps: Version bump to 43.4
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--sci-geosciences/gnome-maps/Manifest1
-rw-r--r--sci-geosciences/gnome-maps/gnome-maps-43.4.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/sci-geosciences/gnome-maps/Manifest b/sci-geosciences/gnome-maps/Manifest
index 68a1fd747fa6..d02ac622faa5 100644
--- a/sci-geosciences/gnome-maps/Manifest
+++ b/sci-geosciences/gnome-maps/Manifest
@@ -1,2 +1,3 @@
DIST gnome-maps-43.2.tar.xz 2334324 BLAKE2B a8daacd9874e9b8d44ae6107b7cc1a0a4a168d579b4101e4da408c08e2509f7da782605b27d089331d3628584783f3fd1d43c26d3bc7b09325810dec7b9b1648 SHA512 dfd7eba5fc0cc38152753d2d3b5ba13cdc614b96fe3f8e6629dc6c56515108fc6f2469f32629ffaba97667b15da294d874653d9133dd13592738379d5fb91c78
DIST gnome-maps-43.3.tar.xz 2334980 BLAKE2B 1c17bf7b85e9b17dde56845180f7f88911d30a405cb8be5703ca9f7fe23c1cfe53b3f412d3ac5c8d1da77b759bf16315774b4eb3fd54f4ca55b71af7afc8e22f SHA512 43cd23d39bdd149635492769065db65716f0ff7e98c37d90e3c48c761308b7362947f7b78c16a3e9279feda0526d4849ba670658bdba4d7c9810817339abc89d
+DIST gnome-maps-43.4.tar.xz 2335020 BLAKE2B 267b4a2a1c8273fdcdccd7f2b385b2c95aa8903d1f5e117affc2174c873931f01cba6d17bfcabd949eb91fbf960469517569a80acd8ecaa45de9a181a7cece9a SHA512 16efd035a940e5ffad6dbbd7d8e527c56fb088211c41d130c0441ae321ea89f3a60524a39dcc5de5bc1caaee408e0eb0fda504471002876b4f3550759939568f
diff --git a/sci-geosciences/gnome-maps/gnome-maps-43.4.ebuild b/sci-geosciences/gnome-maps/gnome-maps-43.4.ebuild
new file mode 100644
index 000000000000..fbde0d6d6cf0
--- /dev/null
+++ b/sci-geosciences/gnome-maps/gnome-maps-43.4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+# Pure introspection dependencies found by grepping imports in ${S}
+RDEPEND="
+ >=dev-libs/glib-2.66.0:2
+ >=dev-libs/gjs-1.69.2
+ >=dev-libs/gobject-introspection-0.10.1:=
+ gui-libs/gtk:4[introspection]
+ >=app-misc/geoclue-0.12.99:2.0[introspection]
+ >=gui-libs/libadwaita-1.0:1[introspection]
+ >=dev-libs/libgweather-4.2.0:4=[introspection]
+ >=sci-geosciences/geocode-glib-3.15.2:2[introspection]
+ >=media-libs/libshumate-1.0:1.0=[introspection]
+ dev-libs/libxml2:2
+ >=net-libs/rest-0.9.1:1.0[introspection]
+
+ app-crypt/libsecret[introspection]
+ media-libs/graphene[introspection]
+ net-libs/libsoup:3.0[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/43.0-tests-timeTest-Fix-tests-for-time-formats-with-diffe.patch
+)
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}