summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViolet Purcell <vimproved@inventati.org>2023-09-21 20:22:14 -0400
committerSam James <sam@gentoo.org>2023-09-22 16:42:47 +0100
commit308d60bf39e9fffb5d632f7ca012b14b406ba0ff (patch)
tree458ec8243be019c3491a8ac692cfa2b374017a33
parentmedia-sound/ardour: Improve libc++ fix (diff)
downloadgentoo-308d60bf39e9fffb5d632f7ca012b14b406ba0ff.tar.gz
gentoo-308d60bf39e9fffb5d632f7ca012b14b406ba0ff.tar.bz2
gentoo-308d60bf39e9fffb5d632f7ca012b14b406ba0ff.zip
media-plugins/calf: Fix build with LLD
Upstream-PR: https://github.com/calf-studio-gear/calf/pull/332 Closes: https://bugs.gentoo.org/740158 Signed-off-by: Violet Purcell <vimproved@inventati.org> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-plugins/calf/calf-0.90.3-r2.ebuild (renamed from media-plugins/calf/calf-0.90.3-r1.ebuild)1
-rw-r--r--media-plugins/calf/calf-9999.ebuild1
-rw-r--r--media-plugins/calf/files/calf-0.90.3-fix-build-with-lld.patch26
-rw-r--r--media-plugins/calf/files/calf-9999-fix-build-with-lld.patch26
4 files changed, 54 insertions, 0 deletions
diff --git a/media-plugins/calf/calf-0.90.3-r1.ebuild b/media-plugins/calf/calf-0.90.3-r2.ebuild
index f0c3d8cae4e9..0d4c5797eb81 100644
--- a/media-plugins/calf/calf-0.90.3-r1.ebuild
+++ b/media-plugins/calf/calf-0.90.3-r2.ebuild
@@ -46,6 +46,7 @@ PATCHES=(
"${FILESDIR}/${PN}-0.90.1-no-automagic.patch"
"${FILESDIR}/${PN}-0.90.1-htmldir.patch"
"${FILESDIR}/${PN}-0.90.1-desktop.patch"
+ "${FILESDIR}/${PN}-0.90.3-fix-build-with-lld.patch"
)
src_prepare() {
diff --git a/media-plugins/calf/calf-9999.ebuild b/media-plugins/calf/calf-9999.ebuild
index ac7a768dcf5c..26b234a8a03a 100644
--- a/media-plugins/calf/calf-9999.ebuild
+++ b/media-plugins/calf/calf-9999.ebuild
@@ -46,6 +46,7 @@ PATCHES=(
"${FILESDIR}/${PN}-0.90.1-no-automagic.patch"
"${FILESDIR}/${PN}-0.90.1-htmldir.patch"
"${FILESDIR}/${PN}-0.90.1-desktop.patch"
+ "${FILESDIR}/${PN}-9999-fix-build-with-lld.patch"
)
src_prepare() {
diff --git a/media-plugins/calf/files/calf-0.90.3-fix-build-with-lld.patch b/media-plugins/calf/files/calf-0.90.3-fix-build-with-lld.patch
new file mode 100644
index 000000000000..451f1baff9e5
--- /dev/null
+++ b/media-plugins/calf/files/calf-0.90.3-fix-build-with-lld.patch
@@ -0,0 +1,26 @@
+From https://github.com/calf-studio-gear/calf/pull/332/commits/bdaaa92dd82e2425e4683b9d496370c5880e3b3e Mon Sep 17 00:00:00 2001
+From: Violet Purcell <vimproved@inventati.org>
+Date: Thu, 21 Sep 2023 19:08:39 -0400
+Subject: [PATCH] Fix build with LLD
+
+LLVM's LLD handles the -retain-symbols-file option (used by
+-export-symbols-regex in libtool) differently from GNU ld, causing
+undefined references during link. This commit removes the
+-export-symbols-regex option from libcalf_la_LDFLAGS since by default
+libtool exports all symbols anyway, so it should not be necessary.
+
+Signed-off-by: Violet Purcell <vimproved@inventati.org>
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -42,7 +42,7 @@ libcalf_la_LIBADD = $(FLUIDSYNTH_DEPS_LIBS) $(GLIB_DEPS_LIBS)
+ if USE_DEBUG
+ calf_la_LDFLAGS = -rpath $(pkglibdir) -avoid-version -module -lexpat -disable-static
+ else
+-calf_la_LDFLAGS = -rpath $(pkglibdir) -avoid-version -module -lexpat -disable-static -export-symbols-regex "lv2_descriptor"
++calf_la_LDFLAGS = -rpath $(pkglibdir) -avoid-version -module -lexpat -disable-static
+ endif
+
+ if USE_LV2_GUI
+--
+2.42.0
+
diff --git a/media-plugins/calf/files/calf-9999-fix-build-with-lld.patch b/media-plugins/calf/files/calf-9999-fix-build-with-lld.patch
new file mode 100644
index 000000000000..816da77f7d0d
--- /dev/null
+++ b/media-plugins/calf/files/calf-9999-fix-build-with-lld.patch
@@ -0,0 +1,26 @@
+From https://github.com/calf-studio-gear/calf/pull/332/commits/bdaaa92dd82e2425e4683b9d496370c5880e3b3e Mon Sep 17 00:00:00 2001
+From: Violet Purcell <vimproved@inventati.org>
+Date: Thu, 21 Sep 2023 19:08:39 -0400
+Subject: [PATCH] Fix build with LLD
+
+LLVM's LLD handles the -retain-symbols-file option (used by
+-export-symbols-regex in libtool) differently from GNU ld, causing
+undefined references during link. This commit removes the
+-export-symbols-regex option from libcalf_la_LDFLAGS since by default
+libtool exports all symbols anyway, so it should not be necessary.
+
+Signed-off-by: Violet Purcell <vimproved@inventati.org>
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -42,7 +42,7 @@ libcalf_la_LIBADD = $(FLUIDSYNTH_DEPS_LIBS) $(GLIB_DEPS_LIBS)
+ if USE_DEBUG
+ libcalf_la_LDFLAGS = -rpath $(pkglibdir) -avoid-version -module -lexpat -disable-static
+ else
+-libcalf_la_LDFLAGS = -rpath $(pkglibdir) -avoid-version -module -lexpat -disable-static -export-symbols-regex "lv2_descriptor"
++libcalf_la_LDFLAGS = -rpath $(pkglibdir) -avoid-version -module -lexpat -disable-static
+ endif
+
+ if USE_LV2_GUI
+--
+2.42.0
+