summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-26 09:13:04 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-26 10:07:11 +0200
commit30bc65c4e575756313b65ad2ff09e16813c9d11d (patch)
treec7ec296c1030c090792de1b396a941d6bf2053e9
parentdev-python/GridDataFormats: Bump to 1.0.1 (diff)
downloadgentoo-30bc65c4e575756313b65ad2ff09e16813c9d11d.tar.gz
gentoo-30bc65c4e575756313b65ad2ff09e16813c9d11d.tar.bz2
gentoo-30bc65c4e575756313b65ad2ff09e16813c9d11d.zip
dev-python/responses: Bump to 0.21.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/responses/Manifest1
-rw-r--r--dev-python/responses/responses-0.21.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/responses/Manifest b/dev-python/responses/Manifest
index 9440a5a42b22..9f4c940b11b7 100644
--- a/dev-python/responses/Manifest
+++ b/dev-python/responses/Manifest
@@ -1 +1,2 @@
DIST responses-0.20.0.gh.tar.gz 45072 BLAKE2B 51864ae6de7328507e74f540f9546f16c5da950ebdb29a13760cc1ff4e1d3736f8e61efdd0ce5a427ea7814a9ffdb936496f9787af74ea2f6565d48f6ecbdfb4 SHA512 cce8d6eca05c23ab12ef7e66297dbe1f613c0ac7d46c20b5ea77639cf5be1807ef55e7c71eb5e915ceaa1bc51293a339f9e22a864da0c30c3a676c6c5bea03cd
+DIST responses-0.21.0.gh.tar.gz 49551 BLAKE2B 3796fd29353f80a04b26a7348153902d959038e072bf512ee4ba8ffd434157c0ce5c37073d114e0d2865c827d82166ee1fcefe2f250c895c23c53664ab919903 SHA512 9e82f0fb7d2a2a4ea071a6384584ba58ebde13504408f8bac351d24df206f0f6815ce3b6d7e013fb87b04d3a1cdccbe7a5287f56f4f9bfb3d4567ad2eeafa778
diff --git a/dev-python/responses/responses-0.21.0.ebuild b/dev-python/responses/responses-0.21.0.ebuild
new file mode 100644
index 000000000000..a1afdacd16d4
--- /dev/null
+++ b/dev-python/responses/responses-0.21.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Utility for mocking out the Python Requests library"
+HOMEPAGE="
+ https://pypi.org/project/responses/
+ https://github.com/getsentry/responses/
+"
+SRC_URI="
+ https://github.com/getsentry/responses/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/requests-3[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.10[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest