summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-05-08 14:06:43 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-05-08 14:07:54 -0500
commit30c581f3748c85d849df22c3bc8aec66c7301eba (patch)
treea10fbe8674691fbe8de5fb4c98276a865fc43228
parenttoolchain.eclass: cleanup obsolete texinfo hacks (diff)
downloadgentoo-30c581f3748c85d849df22c3bc8aec66c7301eba.tar.gz
gentoo-30c581f3748c85d849df22c3bc8aec66c7301eba.tar.bz2
gentoo-30c581f3748c85d849df22c3bc8aec66c7301eba.zip
app-crypt/certbot-nginx: drop 2.4.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--app-crypt/certbot-nginx/Manifest1
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-2.4.0.ebuild50
2 files changed, 0 insertions, 51 deletions
diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
index 5af06ae6bf48..bd680238038c 100644
--- a/app-crypt/certbot-nginx/Manifest
+++ b/app-crypt/certbot-nginx/Manifest
@@ -1,2 +1 @@
-DIST certbot-2.4.0.gh.tar.gz 1333159 BLAKE2B 534c7d090cc8a2b77b2dd8bd8c407409260c18e7741223a327bb240dac9685b1ca152d4a20bb0ec46d8717f89bd3de6f494019c57afe22a74db69641a3ed209e SHA512 c307c97154935a3a01b468d6e91505caba6073b4c01071c87382bdc08c892094d95d75b047047d3221b7d8018a61ce974c0f4defbfdee00b136af920fd579108
DIST certbot-2.5.0.gh.tar.gz 1333903 BLAKE2B 2d30764616d2253fe320ad94182e64cc3e1ce75bd90322fcf7c303a52e32420a57cf84a3acf3f8f4825e058d6fe1e59438b728dacdf9032c4d8797312903825e SHA512 92313e352409d543f260fedee3f376c4750d9428cd39fde3518b162091667173ba6d582b4e91477f7122cf198f24119ecf34b2dce12734afbfc0ebedc395a49e
diff --git a/app-crypt/certbot-nginx/certbot-nginx-2.4.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-2.4.0.ebuild
deleted file mode 100644
index 1e54d1c37e54..000000000000
--- a/app-crypt/certbot-nginx/certbot-nginx-2.4.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1
-
-PARENT_PN="${PN%-nginx}"
-PARENT_P="${PARENT_PN}-${PV}"
-
-if [[ "${PV}" == *9999 ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/certbot/certbot.git"
- EGIT_SUBMODULES=()
- EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
-else
- SRC_URI="
- https://github.com/certbot/certbot/archive/v${PV}.tar.gz
- -> ${PARENT_P}.gh.tar.gz
- "
- KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
-fi
-
-DESCRIPTION="Nginx plugin for Certbot (Let’s Encrypt client)"
-HOMEPAGE="
- https://github.com/certbot/certbot
- https://letsencrypt.org/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-
-S="${WORKDIR}/${PARENT_P}/${PN}"
-
-BDEPEND="
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-RDEPEND="
- >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
- >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-17.5.0[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-2.2.1[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest