summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2020-11-25 17:43:54 -0600
committerErik Mackdanz <stasibear@gentoo.org>2020-11-25 17:44:10 -0600
commit30d7351f6b0e0dc0eda0b5dce1b0c56dd05b7560 (patch)
tree6bc509f0dddc730ed065b6982dbe34f5509cc017
parentdev-libs/hiredis: drop down to ~hppa (diff)
downloadgentoo-30d7351f6b0e0dc0eda0b5dce1b0c56dd05b7560.tar.gz
gentoo-30d7351f6b0e0dc0eda0b5dce1b0c56dd05b7560.tar.bz2
gentoo-30d7351f6b0e0dc0eda0b5dce1b0c56dd05b7560.zip
media-sound/upmpdcli: Bump to 1.5.2
Package-Manager: Portage-3.0.10, Repoman-3.0.2 Signed-off-by: Erik Mackdanz <stasibear@gentoo.org>
-rw-r--r--media-sound/upmpdcli/Manifest1
-rw-r--r--media-sound/upmpdcli/upmpdcli-1.5.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/media-sound/upmpdcli/Manifest b/media-sound/upmpdcli/Manifest
index 5432d35cab28..5d149bc2bbd9 100644
--- a/media-sound/upmpdcli/Manifest
+++ b/media-sound/upmpdcli/Manifest
@@ -2,3 +2,4 @@ DIST upmpdcli-1.4.0.tar.gz 469357 BLAKE2B edd46e86f367ff2f88346cfb4cb249dae44630
DIST upmpdcli-1.4.14.tar.gz 552026 BLAKE2B 0e9722d9a3c278b085416df240d3256ae1eff136f3897b181a59ce9d3edcdfd70ed7e568d8d345b1d0b13a9906f877776d9816ba3e8797c41c1684933aa326e6 SHA512 9084f60a4551fb94be915e6539d59a9ac070d55745c383b1f201c0c83262634c9e6fb353f66bb2232c493752805671b19057cbcec00c5ed128e19e1d0a037976
DIST upmpdcli-1.4.2.tar.gz 477650 BLAKE2B 8bc2f86e8821aaee29f969e6031553f29e3224fdaf4b9c7d443f55bda5f321f36607dbb7dc0af15f0d1e7b006e93595cd1d668f9d1975e8673a80b218ea7f570 SHA512 be855214b55686422689ce786103ff50748a9f9e7e556c8dbeaa7e39e0229a3e0b56502bdbeb7071771706416cd2ff36592cb5245b505d8438f0ba75c200e9c2
DIST upmpdcli-1.5.0.tar.gz 550268 BLAKE2B 8c9c7c3c4d3bdeb7a3a0c4ff506970d8e8ddfa8dffaf7fff525e263817088d599087843707c5154a6fb5441bccbadbee28a80a0bb85561a1418235af3ebc931f SHA512 a04e4b039d72ac8e8b6769bd4794f995f31978f2807aa8f938183cbf0d07f7b16cf9289c9f8c55efea8fa6ba54883cd87135683e524143c7cf0759decc7390ad
+DIST upmpdcli-1.5.2.tar.gz 550460 BLAKE2B e9905fb2f6c07d7374651fd0a9d7ec821d6ea25d4debe1b6e69bbf7def8b75d0b35b245a5e4ca2477832f71a9fe950f7f7635d1b6fc29add0e59405c0c69b338 SHA512 4d6cd44b64637c5a07996a416f0cf15e27e24b84aa04ee3ee9f6f5eda3164a5b964915587a4342cc0a8f95fa175dd106b99242de5c50d3cb603e48450694009e
diff --git a/media-sound/upmpdcli/upmpdcli-1.5.2.ebuild b/media-sound/upmpdcli/upmpdcli-1.5.2.ebuild
new file mode 100644
index 000000000000..0eb2b288b4ea
--- /dev/null
+++ b/media-sound/upmpdcli/upmpdcli-1.5.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="UPnP Media Renderer front-end for MPD, the Music Player Daemon"
+HOMEPAGE="https://www.lesbonscomptes.com/upmpdcli/index.html"
+LICENSE="GPL-2"
+
+SRC_URI="https://www.lesbonscomptes.com/upmpdcli/downloads/${P}.tar.gz"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="thirdparty"
+
+DEPEND="
+ dev-libs/jsoncpp
+ media-libs/libmpdclient
+ net-libs/libmicrohttpd
+ >=net-libs/libupnpp-0.20.0-r1
+"
+RDEPEND="
+ ${DEPEND}
+ acct-group/upmpdcli
+ acct-user/upmpdcli
+ app-misc/recoll
+ thirdparty? ( dev-python/requests )
+"
+
+src_install() {
+ default
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ systemd_dounit systemd/upmpdcli.service
+}
+
+pkg_postinst() {
+ einfo
+ einfo "This package no longer assumes that upmpdcli is driving an"
+ einfo "mpd instance on the same host (https://bugs.gentoo.org/670130)."
+ einfo "Probably it is though, so be sure your mpd is built with"
+ einfo "USE=curl."
+ einfo
+ einfo "Consider installing media-sound/sc2mpd. If upmpdcli"
+ einfo "detects sc2mpd at run-time, capabilities are added"
+ einfo "including internet radio support. See upstream docs"
+ einfo "for more information."
+}