summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-04-12 17:20:39 -0400
committerMatt Turner <mattst88@gentoo.org>2023-04-12 17:27:25 -0400
commit3125aa2c0a194dd76bef5fe5e9f9584c2ed7b40b (patch)
treef61da4cda5e4013f063917fd11efea22a1d4c2f6
parentkde-plasma/kwin: drop 5.27.4-r1 (diff)
downloadgentoo-3125aa2c0a194dd76bef5fe5e9f9584c2ed7b40b.tar.gz
gentoo-3125aa2c0a194dd76bef5fe5e9f9584c2ed7b40b.tar.bz2
gentoo-3125aa2c0a194dd76bef5fe5e9f9584c2ed7b40b.zip
net-libs/gupnp-igd: Version bump to 1.6.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--net-libs/gupnp-igd/Manifest1
-rw-r--r--net-libs/gupnp-igd/gupnp-igd-1.6.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/net-libs/gupnp-igd/Manifest b/net-libs/gupnp-igd/Manifest
index f79fb2a20223..cce463807274 100644
--- a/net-libs/gupnp-igd/Manifest
+++ b/net-libs/gupnp-igd/Manifest
@@ -1 +1,2 @@
DIST gupnp-igd-1.2.0.tar.xz 26100 BLAKE2B a72117b1c3ac3cd95d797b5d7a21b333a46d161bf22bc9649c1649fee6301f16824b0068ee094cfeb31ea283ca0aae8c2369c331fe956f59586ae00fd48c5825 SHA512 0129e743b09cc773b997e0f09d7ab84481d114d52ab273b1e9957960e6a47d686d600492b916970f3b2d3d30c36b68e1e4d049eb7be5d44101a56b90dd5f0af9
+DIST gupnp-igd-1.6.0.tar.xz 29220 BLAKE2B ef90ea50c9bb7fb567d0654626f179012a95cbdbbd233637661f4952e1b0c3493a70b14940a2d7ef598b94c1895e40710d475f79b812f96cfdc1a4e570d5782d SHA512 ebec5f9d7fafc3614dc1c503aa86c7675aedfa05325554576160eaa83386b3da1fef72ef3c79a6fe7213fe64efcb24296ef99da87e90073813af3306df89a7bd
diff --git a/net-libs/gupnp-igd/gupnp-igd-1.6.0.ebuild b/net-libs/gupnp-igd/gupnp-igd-1.6.0.ebuild
new file mode 100644
index 000000000000..5ec22570b0b7
--- /dev/null
+++ b/net-libs/gupnp-igd/gupnp-igd-1.6.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson-multilib xdg
+
+DESCRIPTION="Library to handle UPnP IGD port mapping for GUPnP"
+HOMEPAGE="http://gupnp.org https://gitlab.gnome.org/GNOME/gupnp-igd"
+
+LICENSE="LGPL-2.1+"
+SLOT="1.6/1.6-0" # <API version>-<soname>
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="gtk-doc +introspection"
+
+# The only existing test is broken
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-libs/glib-2.70.0:2[${MULTILIB_USEDEP}]
+ >=net-libs/gssdp-1.6:1.6=[${MULTILIB_USEDEP}]
+ >=net-libs/gupnp-1.6:1.6=[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.10 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ sys-devel/gettext
+ virtual/pkgconfig
+ gtk-doc? ( dev-util/gtk-doc
+ app-text/docbook-xml-dtd:4.1.2 )
+"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ $(meson_native_use_bool introspection)
+ $(meson_native_use_bool gtk-doc gtk_doc)
+ )
+ meson_src_configure
+}